Multiple materials on one mesh set in Blender don't show up in editor

I made a model in Blender and set it to have multiple materials in different faces like this:

It shows up properly in Blender render.

When I import the FBX I only see one material element like this:

According to [this tutorial][3], this setup should work. What am I doing wrong here?

Hi Syneh,

When you import the mesh are you making sure Combine Meshes is enabled?

Yes, Combine Meshes is enabled.

I’m sorry, I misunderstood your question at first. If you have a single mesh, it will only import as one element in UE4. You would need separate meshes > combine on import > and then they will import as multiple elements. A good example of this is the Lava Knight from the Elemental Demo or the MatPreviewMesh that is part of the base content.

For a solid model with multiple textures like you have, I would suggest unwrapping your UV’s by separating them based on texture. Then create the effect that you want using a custom texture.

Another workaround would be to divide up your solid mesh into multiple meshes in Blender and then reimport. If you decide to do it this way there are some best practices to look into.

Thanks, TJ

Thank you for the answer. I’ll try this tomorrow.

I separated the meshes that should have different materials into their own objects in Blender but unfortunately it still has only one material element when imported.

At this point I’m out of ideas what to do. Here is the .blend file if anyone wants to take a look.

With something as small as a road-cone I would suggest using the custom texture approach.

However, I just imported your model from Blender with 2 elements. Make sure that you select both of the elements in Blender and under the Export FBX option > check the the Selected Objects box.

Thank you! That wasn’t the problem but you made me figure it out! I had to change my Blender FBX export version setting to FBX 6.1 ASCII from the default FBX 7.4 binary. You don’t seem to have that option so maybe you’re using older Blender version (I’m using 2.71).

Great, I’m glad you figured it out!

Thanks for figuring it out!