Multiplayer shootout does not work with 4.8

Downloaded example, tried to run it with 2 players from main menu system. Standalone i get message, map specified on commandline ‘/Game/Maps/MainMenu’ could not be found. exiting. When playing in new editor with 2 players window i get this…

after pressing play, Nothing comes up and mouse is not shown. And when i try a dedicated server after pressing play on client 2 i get this…

. Would really appreciate and answer! I have a project that was working with this example in 4.7, but everything i try wont fix this.HELP


I was able to reproduce second issue you described (in which Client gets a black screen after Server initiates Play), and I’ve entered a bug report for it (UE-178890).

It seems other issues may be related to Use Single Process option in your Editor Preferences > Play. Please check if Use Single Process is enabled, and if so, please disable it and test this again. Thank you!


This appears to be related to a couple of bugs with Use Single Process, which were reported here:

Check that post for a workaround. If you still have any trouble after that, post here and we’ll continue assisting. Thanks!

Thanks for reply. Yes i still get this error

no matter what i try in editor. And for some reason your work around isn’t working. I may be not doing it right but should it look like this in side target? I’m using windows 8.

Well, first make sure you follow process of disabling Use Single Process, making sure Editor Multiplayer Mode is set to Play Offline, and then enabling Use Single Process again. You shouldn’t be able to get 2 windows during Standalone anymore, so that eliminates first problem.

Then, in UE4Editor.exe shortcut, add location of the .uproject file to end of Target field (which will already be populated by location of editor.exe). It looks like you may be missing a step in there. For me, I added:

“C:\Users.\Documents\Unreal Projects\MultiplayerShootout2\MultiplayerShootout2.uproject” -game

It looks like you might be missing folder for MultiplayerShootout. Additionally, make sure there’s a space between the .uproject location and “-game”. I think for you, it would look like:

“C:\Program Files\Unreal Engine\4.8\Engine\Binaries\Win64\UE4Editor.exe” “C:\Users\DJINSERT\Documents\Unreal Projects\MultiplayerShootout 4.8\MultiplayerShootout 4.8.uproject” -game

That’s bug, unfortunately, but we’ve entered a report for it and just have to wait until it gets addressed. For now, setting up your shortcuts is only way you’ll be able to use a Standalone process for testing multiplayer (by opening shortcut twice, one for server and one for client, for example).

This shouldn’t happen in a packaged game; bug appears to be an editor-only issue.

Not sure about Bloom, exactly. You can open a new post for that, though, and I’ll make sure we get right people to look into it.

So why is it that I get error of, no main menu could be found? I’m trying to test my menu system with multiplayer, so starting one window when playing offline really doesn’t help. I will try work around again to see if I can get it to work. Will this happen in a build of game? Also why do I get bloom from server showing up in client window? Sorry for all questions and thanks for help.

I tried work around again and still have this error come up.

This is target I’m putting in

I copy paste yours and directly copied it from source on my PC, but still get this error. Its weird because if i click uproject itself from projects folder, it loads editor for project fine. Does not start game though. Man computing is frustrating! lol

Hey DJ,

Looks like your .uproject file is actually “MultiplayerShootout.uproject”. Keep folder name but swap .uproject part out and you should be good to go.

Hello again! So this

is only way i got something to happen but it doesn’t load a instance of game. It only loads editor for shootout. I tried every combination of file, but still nothing. I am sad…

Never mind!!! I just found a nifty little button that says launch game when you right click uproject file. Man I feel stupid! Thanks for help.