Multiplayer Blueprint tutorial not working

I was using this tutorial A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums to try and get multiplayer respawning to work. Besides the fact that I’m not sure how the possessions work, I’m getting errors that arent addressed in the tutorial.

I’m not sure why the cast to node or the respawn node in the game mode aren’t working. Am I going about this all wrong? Or does this tutorial not work with this version of UE4 anymore? Any help is much appreciated. CHEERS!

I see you have a compile warning but not sure what it is. Also although it shouldn’t make a difference but some reason it does you could add the Reference To Self and attach it to the Get Controlled Pawn.

I will follow the tutorial in UE4 4.3 and see if I have issues and can resolve your problem.

I tried to add the Reference to self but the node said its not compatible with it; which I thought was strange. Maybe I wasn’t connecting it properly? I was also concerned by the fact that the respawn node at the end of the controller doesn’t look the same as it does in the tutorial. Sorry for being so vague, this is all still very new to me. I’ll try to provide as much info as I can. THANKS!

Ok finally got a chance to go thru all the mess of building a pawn anyways the problem is simple. Most likely you are trying to spawn the player inside something either the ground or an object. For me using the example map I had to change the MakeTransForm Z to 200 instead of 30. 30 was in the floor so it would not spawn once I made it 200 it worked fine.

Let me know if this works for you also it will not work until you kill your pawn which I can help you set up also if you need.

Thank you so much for going out of your way to help me! But I’m sorry to say that hitting the respawn button for me does nothing, Maybe I don’t have the pawn death set up correctly, maybe i don’t have the possession set up right. What should I do? Are you able to help me further?

Thank you so much!

Will post up a screen shot of the test character as soon as I can with all the steps

this will do all the basic cleanup like when a player dies in multiplayer. After this you should be able to respawn.

if this is fixed please vote up the answer so others will know

It still isnt working. I even played around with the respawn input to make sure it was going in right, Maybe my issue has to do with the compile warnings I’m getting in the player controller? Either way when the player dies I lose all control of that character and hitting respawn does nothing. Sorry to be a bother…

Good NeWs then your dying part is working as the controller is disconnected from the pawn which is correct. So now youre not respawning and if you have compiler errors that could be the problem can you put up a screenshot so I can trouble shoot?

Oh ok cool. Well, its the exact same thing as in the first image, I was never able to fix that. But I’ll add the error details in some more images. This is what happens when I compile:

Thanks again!

Ok best I can come up with is your casting node is corrupt. I would delete that one and the Respawn one and then make new ones off the Get GameMode.

YES! I got it to work. Getting the right nodes to come up takes some figuring. Either way, THANK YOU!

Great glad you got it working.

Sometimes when casting if you make changes to the casted(?) blueprint it will break and needs to be redone but you will likely see the warnings like TARGET is wrong.