Download

Multi Objects Renaming Tool

Hey there! i was wondering if there was a way to rename multiple types of text:

For example right now if you want to rename All the “Oranges” to “Apples” you go

**Text to Find: **Oranges
**Target: **Apples

But if at the same time you want to rename a couple other variables as well, is it possible to that too? Kind of like this?:

Text to Find: Oranges | Carrots
Target: Apples | Relish

This way you rename oranges to apples, and Carrots to Relish! I wonder how hard something like this would be?

Hi,

Why do you need this feature? You can just make it by renaming two times one by one: oranges to apples and then carrots to relish. What the main idea of this feature?

Thanks.

It was to simply avoid doing it one by one if you have to go through large batches at the same time :slight_smile:

I tend to use MORT a lot in my workflow, especially for naming conventions for my assets such as textures, and I’m not the only one.

For example it would be very useful if I could change the suffixes of my “Normal” to “N” & “BaseColor” to “D” and “OcclusionRoughnessMetallic” to “ORM” all in one go!

Can not find MORT Content, 4.17

Hi,

Do you see other plugins folders after checking the checkbox “Show Plugin Content”?

Thanks.

Hi,

Ok, I will think about it but not sure when I could implement it.

Thanks.

Just bought this plugin so I could massrename mod files in the ARK Devkit and didnt realize it was made in 4.5.1 is there any way to make this work with 4.5.1? I would totally pay more money as mass-renaming assets is a nightmare right now.

I just purchased MORT and I think it’ll be perfect for what I’m looking to do. We are using a customized version of the engine on the project I needed this for. It shows up in my library as OTHER instead of 4.18 that it’s based off of. How do I add this plugin to that project?

I tried installing it to the 4.18 clean install I have and then copying the files over to our project folder. When I launched the engine it said I needed to rebuild the plugin. I did so and everything went fine (I didn’t get any errors or anything), however when I restarted the editor and enabled Blutility plugins and tried to show plugin folders the MORT folder doesn’t show up (other plugins show up when I enable that).

Thanks in advanced for any help you provide.
Jamie

Hi,

You can try to fix it by own for your engine version. source code included.

This plugin was inspirational me to create more complex version of renaming tool and managing assets.

You can provide specific lists (array) rename all assets or just use on of many patterns! It is possible to rename 100 assets from provided excel names.
It is also possible to convert tables to TArrays and paste multiple assets into Tarray lists.
More than that - cleaning tool, statistics, duplicates, etc
https://forums.unrealengine.com/community/work-in-progress/110824-asset-assistant

I was able to get this to work. I guess what happened was it did compile properly but I had to check Show Engine Content as well as Show Plugin Content. Figured I would post in case someone else runs into a similar situation.

Hi F1nik, recently purchased your plugin, and it has proved very useful for managing large asset sets.

I’m running a modified version of the plugin, because i have a use case for cropping a file name to the right (like the string.right method). I would be extremely grateful if you would consider supporting this feature in future engine versions. Thanks.

awesome tool. User friendly.

Hi, sure, will try to add this feature in next versions =) Thanks!

Hey, I was wondering if this tool can work to rename components in a Blueprint, or if it only works in the World Outliner/Content Browser?

Thanks!

Hi, this tool works only in the World Outliner/Content Browser.

I have Unreal 4.18 and I can’t install, because it’s saying there is no compatible version of the engine… [REDACTED]???

Hi. This is weird, try to delete mort and then get it from marketplace with installed 4.18. Also you can try to ask UE support team. Thanks.

Hi, very new to Unreal… I just purchased MORT and it doesn’t show up in Unreal. When I’m in the Epic Launcher in the "Vault"section of the Library it says that the plugin is installed to all compatible versions. I’m running 4.20.3 and I’ve tried launching and relaunching the project. I’ve set the Content Browser to show all content.

Thanks!
rob

Why not allow users to use regular expressions ?

0B60E54A978847DB9F38500EEEBD1BC6.png.jpg