Moving objects leaving a trail behind

Hi

I have this issue, when my cart is moving from left to right it leaves a trail behind.
I tried to disable motion blur, but no luck.

Thank you in advance

Could this be post processing simulating motion blur, or even the cart material?

My first thought is that this has to do with lumen. (The shadows on the cart are being calculated with lumen, and it’s taking time to recalculate shadow locations when cart is moving)

Try setting: Project Settings → Dynamic Global Illumination Method → None

I second @Astrotronic , possibly due to multi-frame GI, disable it and see if it changes, also do it in any post process volume

My Dynamic Global Illumination Method is already set to None.
I have noticed that the trail disappears if I get closer to the cart or I am constantly moving.

I have motion blur turned off.
I have tried changing the material to see if that is the problem, but it keeps happening.

Just for fun, try to turn off Anti-Aliasing, or switch to a different method. Because i noticed in some of my test projects, that in some cases, AA is responsible for very similar looking trails.

Still no luck… :frowning:

Hmm… One path forward would be sending us a sample project to poke at.

If you just create a new blank project and add cart+movement functionality, you could then File → Zip Project and it will make a neat little .zip project with only cart assets.

Well… As much as I tried creating a new project and then migrating the assets or even the map, I can’t seem to recreate the problem. I am so confused.
Maybe it is something in my project settings.

You can check YourProjectFolder/Config/DefaultEngine.ini any non-default project settings should be saved there.

DefaultEngine.ini (20.1 KB)

I don’t see anything wrong

What if you turn off ray tracing? ( I spotted ‘r.RayTracing=True’ )

No luck… I have also tried copying all the rendering settings from “DefaultEngine.ini” to the new project’s “DefaultEngine.ini” and I still cannot replicate the problem…

Does the engine version you are using Verify properly? (epic launcher button).
Does it happen on UE4?
That would solve some questions.

I have verified my engine and it’s good to go. I can’t get any of my UE5 assets to work in UE4.27.2. The assets exist in Windows Explorer but are not showing up in Editor.

That is expected. Assets can move forward with engine versions, but not backwards.

2 Likes

Here is a video of the problem and camera component

Huh, crazy idea, if you cannot replicate this problem in a new project with your migrated assets etc. : Why not simply create a new project, migrate everything over there, and if indeed this problem does not appear again, use this new project from now on :slight_smile:

Sometimes some settings get jammed, and do their thing/weird stuff regardless of what their settings say. Copying everything in a clean project then is probably the easiest and safest way to solve it.

1 Like

That worked :))))