Download

Moving noise on shadowed surfaces

Hi,

I’m encountering moving noise on shadowed surfaces in the 3rd person shooter template map (in 4.24.3 and 4.25.3). I work on a rather solid computer for Unreal as of lately:

AMD Ryzen 5 3600 (3.6 GHz base)
RTX 2070 Super
1 TB SSD
Gigabyte AMD B550 motherboard
32 GB DDR4 RAM (dual channel)

I’ve tried a ton of changes to Project Settings and lights. I’ve tried static, stationary, and movable directional and skylight. Various settings for those. The one thing I changed in the post process volume that removed most of the noise I’ve encountered (as there’s a couple other instances of fine-grain noise which were inside 3D models and on the surface of one of the starter materials). The moving noise is exactly that. It looks like a usual type of noise (splotchy, low-quality results of lighting) that’s moving in a sort of streaming fashion across surfaces that are shadowed. I tried a few different programs for recording a video of it, but all were too low-quality and slow in output to be useful. Tried turning off ray tracing, and starting a new project with ray tracing disabled, and it’s the same problem. Funny thing is, I didn’t encounter this moving noise on a laptop I was previously using. The laptop is a far lower spec computer than the one I’m getting the noise on (2.4 GHz dual core, 6 GB DDR3 RAM, integrated Intel graphics 5500U), and I never experienced it on there in 4.24.3. The noise primarily shows / occurs when I’m moving the camera around, whether it’s rotating it or otherwise.

Any questions and/or ideas to solve it?
Thanks

Is it possible that it has anything to do with anti aliasing settings? I’m not a pro user, just started a few months ago but that solved some issues for me a while ago.

I was thinking it could be at least a part of it. I’ll try to change the anti-aliasing cvars in console and use different combinations. The scalability settings are at Epic, and I tried all High, and it didn’t work. However, I think there’s a few extra settings for anti-aliasing accessed through console cvars that I haven’t tried. I enabled and disabled Temporal Upsampling, and it didn’t improve.

One of the changes I attempted was selecting Brute Force mode RTGI, and increasing the samples higher than 6, and the FPS slowed way down. There might be a problem with the latest update for the graphics card driver, which is 452.06 released on 8/18/20. I had heard of other driver updates seemingly resulting in issues with RTX cards. Yet another possible cause is something with DirectX. I tried a non-RT project, with DirectX 11 enabled in settings, and it was still occurring there, but seemed less so.

Raytracing is inherently noisy, you can’t generate enough samples to converge on a noise-free result in realtime. A denoiser is used to improve the result but it won’t be consistent from frame to frame so you will still get spotting, especially in low/indirect lighting when using final gather.

So, there’s no excellent-quality level, dynamic lighting with ray tracing?

I don’t understand how ray tracing is doing it if I experienced it in a project with ray tracing entirely disabled. Actually, I tried a ray tracing enabled project a bit ago, and turning off ray tracing in the post process volume and even for a chair in the template scene I turned off “Visible in Ray Tracing” and it was still noisy. The noise would move on certain surfaces and not others. For instance, the chair from the starter pack (with a yellow back and seat and brushed metal frame), initially had motionless noise. When I changed settings to disable ray tracing and use SSR + GI (non-RT) + non-RT AO, the noise started moving on the yellow parts of the chairs. With ray tracing on, and using 6-8 samples per most RT settings (reflections, translucency, Brute Force GI), the noise was horrendous in everything. This is using a stationary skylight and stationary directional light, and after adjusting auto exposure to Basic (Min -10, Max 10). Even changing back to Histogram with the defaults did not recreate the better quality before once I had built lighting. It’s possible there’s a problem with my new RTX 2070 Super or the hardware settings for my computer. I built the computer from components ordered off of Newegg, and may have screwed up by placing an additional layer of thermal paste on the top surface of the CPU I installed (not knowing there was already a layer of thermal paste on the underside of the fan/heatsink I installed on top of the CPU). In addition, when cleaning off a bit of excess thermal paste from the edges of the CPU and the top of it, as I was pulling the paper towel away from the motherboard, a tiny string of it dropped onto the top area of the graphics card PCIe slot. I cleaned most of it off, but there was about a tiny droplet remaining on the inside of one of the contact slits in the side of the slot (but at the top, so I don’t think it fell further into the slot and covered a contact). Perhaps it’s a matter of removing the graphics card to see if there’s some thermal paste in there still, or waiting until it withers down to the point of not affecting things, if it is affecting the Unreal RT results lol.

I don’t know if it was evident, but I’m new to building computers. Is a Ryzen 5 3600 compatible with a 2070 Super to use Unreal Engine? The motherboard and graphics card are 4K compatible, and I have a 4K monitor @ 60Hz which is the limit to the motherboard (AMD B550) refresh rate support. UE works much better in terms of not having noise from low ray tracing settings on the other computer I was using before this one. It’s too slow for other things in UE though. Now I get super fast material preview displaying, faster loading time for the engine, faster shader processing, and pretty much everything except quality rendering results (static and dynamic, or mixed).

Well none of us can see what is happening so these are quite literally, blind guesses.

Seems unlikely to be a hardware problem, I’ve had faulty hardware in the past and I have never had a problem that was isolated to a single application. But again, can’t see it so who knows.

Right. It is isolated to a single application so far. I’ve played a few games, watched high-res videos, changes the NVidia control panel settings without major issues, and used a music production application without a bad problem too. The graphics card is the only one in there, no integrated chip on the CPU. Thanks for offering ideas. I’m doing some testing in a new project, and there’s signs that it’s not ray tracing itself that is the problem. I haven’t altered any cvars either yet, so there’s that to attempt. How do I get the definition or information about a cvar to display in-editor or in the console? I saw a post about it, but I tried with no result.