Movie Texture doesn't work after package

Hello!

As stated, the Movie Texture doesn’t play after I package the project. Everything works fine on the PIE.
After package, there’s only black screens where the movies should be playing.

I have tried blueprint controls, relative url, playback rate and can’t seem to find a solution.

13lumes,

Could you please provide additional details about your movie texture? What type of file are you using? Does this happen with various types of movie files? Are you using the binary or source version of the engine?

Looking forward to hearing back from you, thanks!

Hello Samantha!

Well, it’s a 3MB .wmv, I’ve tried .avi and .mp4, all to no avail. The movie plays fine on the PIE but not on the package (except .mp4 that doesn’t play at all).

I believe I’m using the binary version. Is there any way for me to confirm?

Have you taken a read over our documentation to make sure you are setting up your media player asset correctly?

Media Framework

You need to place it in the Content/Movies folder within your folder directory so it packages and plays correctly in your project.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Hello Andrew,

I have and ther movie is on the Content/Movies folder… I made a blueprint with set texture parameter and simulated the video (it was a karaoke kind of thing) but I never found a sollution for the problem.

It could be how you are calling the actual media player asset to play within the blueprint. Could you provide me with some screenshots or some simple steps to reproduce the issue on my end?

I wrote a simple tutorial which might help you resolve your issue. It goes through the process I use when calling the media player asset to playback in your project within a blueprint.

Media Player Asset Tutorial

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

I do believe I have followed your tutorial.
I no longer have the blueprint but I’m curious aswell so I’ll do it again as I did it and cross check with your tutorial and I will be back to you :slight_smile:

Thank you

Its still an issue in 4.18. Movie placed in Content/Movies folder, it works in PIE and Standalone, but doesnt in packaged version. Only black material shows.

Did you ever get this resolved? Im having the same issue.

Screenshot_1
To prevent my UMG Only project from rendering anything 3D, I tried this and the video was not showing, breaking the wire/enabling world rendering made my video come back. Weird as it shows in the PIE.