Movie Render Queue - Path Tracing - Poor mipping


This pictures below were rendered in the movie render queue using Path Tracing. I have no idea why, but the ground textures are supper lowres. I’ve put this down to the engine mipping the textures, as you can see in one of my pictures it’s gradually getting more low res the further away the mesh gets.

Below: The imagine in green is how it looks in the viewport.

I’m using virtual textures, and the textures you can see have been set to ‘No mips’. I assume being a virtual texture this works differently.

How can I improve the mipping so it’s not so drastic?

Below: The resolution of the texture (sample).

I have denoise turned off.

If anyone has any questions, or needs any extra context I’m happy to provide.


1 Like

I think MRQ is pretty messed up when you want to use it with pathtracer(weird blurry filtering over image, tonemapping seems off and high amount of spatial samples will crash gpu).

I use legacy video capture option in sequencer when I want to use pathtracing, maybe try that option. I think if this issue you describing isn’t present in editor then it wouldn’t be in legacy capture either.


Hey UEIaci,

This was a really smart idea, so I tried it… In the image below you can see it rendering fine in the preview window. On the right you can see I’m using the legacy sequencer.

However upon checking the output, it’s just just giving me black empty images (?). I tried finding a solution for this, but seems I couldn’t find any answers.


Thanks for your response!


I think I solved the issue, it was a multiple of things causing it. I turned the rubber marks into a static texture and not virtual texture as this was a decal. Maybe there is a bug here with virtual textures/path tracing/decals?

The asphalt blur was related to the camera aperture being set too low as it was naturally blurring.


To be honest the asphalt still looks blurry at the focus point but looking at a normal photo this kind of looks correct. Maybe I can just adjust the contrast of the asphalt to pop a bit more.


Ah yes I forgot, first few frames turn black for me too.Not sure why, maybe some other bug.

EDIT: You might also need to fix exposure to manual, but for me even then 2-3? first frames are black.

1 Like

Thanks, pro tips. I’ll give it another shot. :+1:


1 Like

I have the same problem when rendering with path in version 5.1. I just want to render an image and I get blurry with no reflections and lots of errors. In the viewport it looks good, but rendering in high quality is the problem. does anyone know the problem?

1 Like


Please could someone explain how I can use the Legacy movie renderer with Pathtracing? I could find no answer anywhere. I’m getting tons of issues with MRQ, mostly soft and bad images which look better in the viewport than in the render.

Any help would be appreciated.