movie render queue color matching

Hi, I’m facing an issue with color mismatch between the viewport and the final render when using the render pipeline queue. The colors do not match, and it’s unbearable to work this way from an artistic point of view. What settings should I use to ensure COMPLETE color consistency?


So I do not use the Movie Render Queue, and as such, the little ins and outs of the application elude me.

That said, what I do know is that what you see in the VIEWPORT is NOT what may be represented IN-GAME and this almost certainly is the case for you.

You can try this out by opening a level with a few static meshes in it, add fog, sky light, sky atmosphere, post process and a directional light. If you lower the angle of the directional light to below the horizon to get a night time effect, what you’ll notice is that in the VIEWPORT, you’ll get some “extra” lighting, but the moment you hit play, everything will appear black.

So check this thread out, if you haven’t already:

Also, are you using Static Lighting or Lumen?

That matters as well, because if you want your lighting to be unchanged, it needs to be built, and if you’re using Lumen, you’re naturally going to get variation in detail. You may want to use Static Lighting if you want the same exact outcome every time (in which case you MUST disable Lumen.)

Thank you for the detailed response. The issue I’m facing is a bit different. The image in Play Mode is the same as in the viewport, but when I render using the Render Queue, the grass appears greener and the gamma seems higher. I’m using Lumen for the lighting. This discrepancy is very frustrating, especially for achieving artistic consistency

Are you using the Ultra Dynamic Sky? Are you viewing at a lower scalability in the editor than you are rendering?

I use dynamic skylight and skyatmosphere, i dunno if it is “Ultra”. Scalability is set to Cinematic both for viewport and queue.

Can you try disabling Game Overrides?

1 Like

Not really, I have a large landscape and I use Game Overrides to disable ‘Flush Grass Streaming’, otherwise the engine crashes. Do you think one of the overrides could be causing color mismatching?

It must be something about grass itself.

It forces LODs and shadow distance. Maybe its a shadowing issue.

Yeah, thank you very much! It is about some override, going to figure out which one!