Movie Render Queue Blueprint Issues

Hi all,

I’m a newbie in Unreal and I’m trying to create very simple Blueprint using the MRQ. I’ve been using the Movie Render Queue in Runtime Builds tutorial. The Rendering window does open but it shows only a black image as preview, renders the closes and then I see the preview. The renders unfortunately don’t get saved to the designated folder.

Using the pipeline config, I can change the settings like anti-aliasing but changing the output folder doesnt result in any files being there.

The output log reads “LogMovieRenderPipeline: Error: Not all frames were fully submitted by the time rendering was torn down! Frames will be missing from output!” but no matter the duration of the process, there is not a single frame in the output.

I have the blueprint attached. Thanks for any help!

Greetings!

So I had this same problem with trying to use Movie Render Queue for a holiday project. Then today I looked into the problem again with another project and found a short video on William Faucher’s channel from a 4.26 video regarding movie render queue.

What solved the problem for me, was the bit on deferred rendering. Go into the configuration settings and then the deferred rendering tab. On the right-hand side, drop down the options for “Additional PostProcess Materials”. Add an array and then in the material box add the material “SceneDepthWorldUnits”. Make sure to check the box to enable it as well. Then render local as normal. For my fireworks display test, it worked perfectly and looked way better than the normal sequencer render (legacy).

I’m gonna test other more complicated blueprints in the future with this setting and see if that solved the error completely. Here is the link to the video from William.

Anyways, hope this helps!

~ Mary

Hello,
What kind of variable type is Pipeline Config in your example?
Congrats