Download

Movement not being replicated in standalone game - PIE fine. "Hit limit of 96 saved moves"

I recently tried to test my game in standalone rather than PIE and I found that my movement is not being replicated. Actions like attacking seem to work fine but no player can see any other player moves. When I look at the client logs I see it flooded with this

[2021.05.16-13.32.11:171][815]LogNetPlayerMovement: Warning: CreateSavedMove: Hit limit of 96 saved moves (timing out or very bad ping?)

There is nothing logged in the server while this is occurring so it seems something might be preventing network traffic from client to server.

I tried setting the rate values in the DefaultEngine.ini from this post but it has made no difference.

This is occurring in 4.26. It can be reproduced in PIE if I disable “Run Under One Process” but otherwise PIE works perfectly fine. Any suggestions for things to try?

You usually get this error message when the client lost connection to the host. If you wait a minute or so, you’ll probably time out as well. Maybe you are trying to connect to a wrong IP/port?

I figured it out - it was a really dumb piece of code I had added a while back. My movement component wasn’t enabled by default so I could enable it when things had loaded. But I seem to only be enabling it for the owning client and no one else. As a test, I set it to enabled by default and confirmed things work.

1 Like