Download

Movable point light differs between editor and in-game!

In the editor, a point light correctly gets blocked by a movable mesh. In the game, that does not happen:

How can I get the game to behave like what I see in the editor? (I’ve disabled static lighting project wide.)

Is it being blocked in editor by a dynamic shadow? You can disable the shadow on the light and see if it looks similar. I wouldn’t be surprised if VR didn’t support dynamic point light shadows since they’re pretty expensive, but I don’t know if that’s actually the case. I’d start there though

Yes, you are correct. If I disable shadows it does look the same.

That is really disappointing. In Unity, VR supports any type of shadow, there’s just a limit on the number of lights (which you can override if you wish). I don’t have many lights in this scene, so I was hoping Unreal to do better.