Download

Movable objects too bright

I have a scene that’s lit with static lights, however when I put a movable object in the scene its way brighter than the the static objects in the scene ?

Whats the best way round this ?

W_Wones

I’ve noticed this also. I’m not sure what causes it or how to fix it, sadly.

It looks like movable object get some of there lighting from the irradiance cashe, if I turn this feature off, my movable objects go as dark as my static ones.

I had altered the environment colour under the world light mass settings, putting hti back to the default black, helped but its still not ideal, any thoughts from anyone ??

I experienced this problem back when I had a stationary directional sun light that would shine through the backface of a ceiling. The static objects weren’t receiving the extra sunlight because I had an invisible blocker that was used during the bake, but it couldn’t interact with the dynamic shadows at runtime. So,

  1. Make sure only the correct lights are being cast to your movable object. Maybe it is receiving an extra dynamic light that is leaking through something thin.

Also, the default sun strength (and intensity of most lights, really) is pretty high. So when the engine tries to approximate a brightness for the object, it might guess higher than you’re expecting based on the nearest indirect lighting sample. If you go to Show > Visualize >Volume Lighting Samples, you can see the little light nodes that Lightmass builds to give a brightness to your object. If there aren’t many of those samples, it could be assigning the wrong one. You can increase the amount of these light samples in World Settings > Lightmass > Volume Lighting Sample Placement Scale. Setting this to .5 should double (I think) the amount of samples in the map. If there’s a specific area of your map that you know will have Movable objects, you can place a Lightmass Character Indirect Detail Volume, which will make a big chunk of samples in a specific area.

So, 2) Make more Volume Lighting Samples to get more accurate approximations of brightness.

I have a game with the core concept to place movable items in a static house that has some Stationary lights here and there. It looks pretty great. This movable chair is in a 100% static environment.

StephaBon

Thanks for the answer, I have tried turning my lights on and off to see, what my be causing the issue, but can’t find the culprit. Would I have to rebuild lighting after changing each one ?

I have a movable light for the sun, which turning off doesn’t seam to affect things, and a skylight with cast shadows on, my objects are inside a “room” so they are in shadow as far as this light is concerned.

I have also added a lighmass character volume, and it didn’t change things, although I don’t see extra samples in the volume with the view volume samples option in developer visualize menu.

Looking at that view, there is a light sample pretty close to the object I want light correctly. so I am pretty confused right now.

Your game looks very good BTW keep up the good work !

all lighting in engine usually has a wide variety of settings, I’d try adjusting them till you have the effect you want, also something as simple as moving them around sometimes helps.

also the object itself might be the culprit, it’s materials & the settings etc in there, this occurs frequently when importing from various modeling programs, the material settings will change or have different effects in unreal engine. you could adjust like roughness & turn down specular etc. if these aren’t already being used in your materials, add them by holding the number 1 down n clicking , this adds a node that you can adjust when connected.

My materials aren’t imported, they are just fairy straight forward ones I am using on static objects,where they look alot darker.

I wish I could post a screen shot but there seams to be a problem at the moment.

I’m sorry for your frustration. I know the feeling.
The light samples are made by Lightmass, so you need to rebuild lighting to add the new ones. They are also constrained by your Lightmass Importance Volume, so make sure you have one and it is the right size for the best results.

Did you increase the number of Volume Lighting Samples? That should be pretty easy to tell in that visualize mode after building.

I ran some tests on that Character Indirect Lighting Volume. Turns out it doesn’t add an extra concentration of lighting samples, it just forces Lightmass to build them in areas that it would ordinarily deem unnecessary, since it only builds them at player height.

But it sounds like the samples aren’t your problem if you’ve got an object sitting right on top of one and it’s still super bright. The only other tweak to rule out the volume samples is to crank up your light settings if you haven’t already. I’ve got Bounces at 100, Indirect quality at 6+, Volume placement scale at 0.5, and Production build quality. Maybe the samples just aren’t good at getting accurate measurements without the refinement of the indirect quality or something. But I suspect this isn’t the case.

Like I said, I had this issue only when a pesky dynamic (or stationary) light was sneaking in through a backface. I would turn off all dynamic lights and see what happens after rebuilding lighting for good measure. I don’t know what your room setup looks like, but make sure there are thick blockers and everything is set to cast dynamic shadows. In my experience with sky lights, they tend to create an ambient light for things that are supposedly out of their view, so turn down its intensity or disable it. Turn down or disable your directional light as well and rebuild.

After reading your other posts, it sounds like you are doing everything right, so I’m running out of advice.

I am pretty sure its the skylight that’s doing this, the problem is I want the sky light on so I don’t have 100% black shadows when the player is outside…

I can juggle the settings so they look OK, not too bright on movables, but not so dark I get black shadows, but its hardly ideal.

Maybe there’s away of doing this via a post process volume ?

Maybe have a trigger that activates the skylight when only going outside. This depends on how complex the level is and how many times you would have to implement this workaround. You can use the Post Process to Tint Shadow setting under Film to give shadows color, but I don’t know if this will also brighten them.

StephaBon

You’re a clever clever chap, I’ll have an experiment, and report back.

Thankyou.

I find the solution!

select your sky light, go to the detail panel and then > cascade shadow maps>dinamic shadow distance stationary light. and then put the number to 20K. at least this worked for me

Movable objects lack indirect self shadows that reduce overall brightness its good idea to always bring pre-baked ao maps to engine

Hello Jones, did you solve the problem? I’m having the same issue I think

If you disable ambient occlusion from lightmass settings then movable objects fit much better to scene.

Hello, I could solve the problem by increasing Static Lightning Level Scale from 1.0 to 0.3 From Lightmass Settings From World Settings.

Coming for a more general 3d background there is a rather common problem with texture based materials as in most cases they are not properly colored balanced for the given environment so as a movable object the material applied is generally ignored as to the “balancing” behavior of the lighting set up. The result will usually be to bright for dark sets or to dark for light sets so to balance the result to fit the set you need to balance the material manually.

From good better best.

Good
You can plug the diffused color into the emissive and add a multiplier to control the output.

Better
You can select the color map texture and set it’s output at the texture level.

Best
Use a instanced material that can control all levels of output

The best solution is what I generally use as it gives me complete control of the color balance for color as well as normal,spec and roughness.

Example of the good better approach

https://youtu.be/9Te1OC0bjb4

I realize this is an old thread but i just solved this for myself. On the movable object > Lighting > Choose Force shadow map instead of the Default which is volumetric map for movable objects. I don’t really know the full implications of this but for my scene it made the movable objects lighting exactly like the static ones. Hope this helps anyone !

Ton’s of answer no one is proven to work, @Poetfall I don’t see that option “Force Shadow Map” on an Actor, you mind taking a screenshot?

this option is here :