Download

"Movable" objects render too light?

I am currently creating a visualisation of a living room where certain objects can be tweaked/swapped.
However i have found that for some reason all objects that are set to “Movable” seem to be unnaturally bright compared to their environment.
0y8vP1L.png
Note how the table and chairs in the background is “static” while the couch is movable

Is there a way to fix this issue?

Static lighting for dynamic objects is stored in lighting samples placed automatically by the lightmass process. These are only placed above surfaces in LightmassImportanceVolumes so the first thing you need to do is to make sure you have one of those.

To reduce flickering and to mask the fact that these samples are quite sparsely placed they are quite heavily interpolated. If you happen to have a brighter area nearby, for example on the floor below, the engine might be blending in some of those samples.

Try turning on Show > Visualize > Volume Light Samples in your viewport to see the placement of these samples. For detailed small interiors there might be too few of them. If this is the case you can lower the value for volume light sample placement in your lightmass settings to something below 1.0. Be careful not to go too far as this will increase both build times and memory usage.

A skylight or some other types of stationary lights can accidentally blow out models that they are getting to.

However, the average brightness of that model actually seems pretty accurate. Because your scene has high contrast and low lighting, it just sticks out because there aren’t a lot of shadows covering up different areas. You can try to make a nice AO map to fake some of it, or enable Distance Field Ambient Occlusion. Increasing indirect samples like Arnage said can help in many cases, but it looks like your above scene has too much shadowing to fake with any quality of lighting cache. You need actual shadows provided by a dynamic light. Or just make your scene brighter.