Download

Movable objects and baking - problem

Hello,

How can I make a movable object blend well with the rest of the static objects (that have already been baked).
I have a door that is movable and it just pops out of the level, like it doesn’t belong there.

Is there any workaround that I can make, to make it blend with the rest of the environment?
Thanks

c81b2490c2bdef2145bbb0fba5a699596ec3b70d.pngdoorPROBLEM2.png

You can try with the option “Light as if Static” on, inside the Lightning tab of the door.

Thank you NasteX for the suggestion.
I will try it and I will let you know if it works.

Doors are an issue, the engine uses a sort of light environment probe to add indirect lighting to dynamic objects. Works fine for things like a character, but for a door you have drastically different lighting on the inside and outside and it blends the two together.

Like darthviper said, movable objects get their lighting by sampling one or a few lighting samples (Show > Visualize > Volume Lighting Samples). No matter what, you can’t get it to feel grounded in the scene without all the AO and precise lighting that you can easily get on static objects.

“Light as if Static” will mess things up for you. The areas where the wall and door meet will be completely black, and the two separate rooms will clearly have shadows and lighting from a closed door. You may have to use a different colored material to fake what you want.

Either that or use dynamic lighting for everything

Thank you all for your input.
I think I can live with the occluded areas where the door meets the frame and I will have to make the rooms be evenly lit, so there won’t be that much noticeable difference from each side on the door.

Do you have the indirect lighting detail volume on the map?

If you mean LightmassImportanceVolume - yes I do have surrounding the whole apartment

Actually, never mind. I thought that the indirect detail volume places a higher res grid in the volume, but reading documentation it doesn’t.

Maybe try the “Indirect Lighting Cache Quality” setting on the door mesh and set it to “ILCQ Volume”.

Sometimes all you need is Dynamic material instance and per object AO scalar parameter that you hand tune to match the look.

What if you set the door to be hidden, And then set it to visible in the level blueprint?

I tried setting the “Indirect Lighting Cache Quality” to “ILCQ Volume”, but it turned up even worse.
I also lowered the “Volume Light Sample Placement Scale” in the Lightmass settings to 0.25 (the default value is 1), so there would be more samples, but still to no avail.

057a7cc7a1eccc39756159d70db1c2aaef144586.jpeg

I tried this and it doesn’t make any difference.

Could you explain a bit more in detail, so I can try out your suggestion. Thank you.

I think he means adjusting the color of the object specifically so that you can try to make it more closely match.

Any luck? I’m running into the same thing. I really wish we could tell ue4 to bake specific objects at a certain time and then tell it not to count it on the rest of the light bake.

Just try to bake with higher setting, and hope that the movable object will start getting more acurate reflection.
I’ve got resonably good quality by just playing around with the lightmass.ini file and the lightmass settings in the editor.

I’m not sure that it will work for every situation, but all other things I’ve tried so far didn’t work.

If I do find a overall better way to fix such issues I will post it here.