Movable light bleeds through static mesh

Hello. I know there are lots of questions and answers regarding to this issue. But non of them are solid solutions. I have a bookshelf with 2 cm thick walls, and movable light. Light bleeds through wall of shelf. Tried changing shadow bias and sharpen filter, it lets me to lower the bleeding but does not solve it completely. Also I do not use any lightmap UVs as my lights are all movable. And I know, making thick walls is a workaround for this. BUT

I just want to know how to solve it completely if possible. Or are you planning to fix this issue on some next versions?

1 Like

Hi Nicat,

I want to go ahead and preface that this is not a bug and changing a couple of parameters in your movable (dynamic) light will help with this.

Without seeing a screenshot of your specific issue, I’ll use a broad example that should help regardless. There are limitations with using movable lighting with cascaded shadow maps and I’ll discuss those at the end.

Select your movable light:

You’ll want to adjust the following settings to get a result that works for you: Shadow Bias and Shadow Filter Sharpen.

In the following examples I’m using the architecture meshes from the starter content.

  1. Shadow Bias: 1 and Shadow Filter Sharpen: 0

Here you can see a lot of bleed created by the shadow bias.

  1. Shadow Bias: 0.5 (Default Setting) and Shadow Filter Sharpen: 0

In this you can see with the default settings you still get a little bit of bleed around the bottom corners

  1. Shadow Bias: 0.0 and Shadow Filter Sharpen: 0

Here you can see the artifacting cause by cascade lines by adjusting the shadow bias too low.

There is no clear simple answer when using Dynamic lighting without employing some other methods of lighting as well. Using thicker walls, static lighting with lightmap UVs, or even using Ray Traced Distance Field Soft Shadows (a new form of dynamic shadowing in the editor) can help, but the last suggestion still has some limitations with landscapes and a few other things.

If you need sharp shadows using a combination of static lighting and dynamic lighting would be the best result.

Thank you!


not working