Download

Motion Controllers offset from HMD

Hello all! I’m having an issue where the motion controllers seem to be rotating around an offset from the HMD. The Player Pawn itself is correctly starting at the same origin as the HMD, but the controllers are offset. The easiest way to see it is in this video, wherein I am holding my arms straight out in front of me and spinning in place. You can see how the controllers are rotating around a different pivot:

My motion controller setup is the same as in the documentation.

Please let me know if you have leads, thank you!

did you ever find a solution to this? Im having a similar problem where my controllers are rotating when i turn my hmd, and when i walk around they move way far away from me.

I encountered something like this before.

What I did was basically place the PlayerStart somewhere in the air and in the Level Blueprint, set the location of the player Pawn to 0,0,0 at beginPlay.
This fixed it for me.

Im having the same issue. Setting the player pawn to 0,0,0 in the level blueprint did not fix this for me.

I figured out a solution, it might not be ideal, but if you make a separate pawn with just the controllers in it and either place them at origin or spawn them at origin, it works.

Keep in mind you’ll still need to do you button logic in your player pawn because thats what we are controlling. You can get actors of class to find the pawn you made for the motion controllers and get their location and orientation that way.

It would be great to find out how to get them to work within the same pawn.

Best of luck!

Do you have your controller’s meshes offset in the Blueprint? This has happened to me when I do not have the meshes at 0,0,0 in the Blueprint.

54ccb73a24945fc796992c3d5e750db7e9f3c748.jpeg

At 0,0,0 the controllers have the same offset effect.

I attached an image of what the Pawn looks like. The only difference from the Motion Controller Documentation is that it also includes the Camera and SteamVRChaperone. When the controllers are in a separate Blueprint from the Camera and SteamVRChaperone they work as intended. However it creates more work having to pass information between the two.

You need to turn off camera inheriting rotation thing. I had this problem and fixed it. I believe that is how.

What component and which setting? The Yaw Pitch and Roll on the pawn? Disabling them makes the head cam not update. I think I’m missing the specific one your referring to.

Maybe this will help. There’s a few videos that go thru the setup from a blank project maybe it can help you catch something.

Thanks! it seems that I should move my project into 4.11. In 4.10 that setup still doesn’t function correctly.

Yes that is true. In general if you can go to 4.11 for VR would be for the best due to the changes they made to handling the HMD and making it easier to setup. I noticed no one asked the version before so that could have been where some of the problems came from when trying to help out.