Motion Controllers no longer work in version 4.24

I’ve been really struggling with this issue. I posted this issue on theanswer hub and on stack overflow but I still am no closer to solving the issue.

I updated my project from 4.21 to 4.24 and the motion controllers in my game stay on the floor and dont move. I can see the controllers moving in the vive home screen but in my game the hands stay on the floor not moving. I tried copying the default Steam VR bindings from the sample VR game template but that did not work. I’m running out of ideas and I’m really stuck since the motion controllers are the main part of my game.

Is there a C++ VR template for 4.24? I could use that to try and compare against my project if there is.

Hi Katianie, I take it you are talking about when you package your game and try and run it ? I have been using 4.24 extensively for VR and have no problems running my game in the editor but as soon as I package it and run it the hand controllers stay on the floor. I tried numerous work arounds people suggested like copying the bindings folder over into the package game. I even upgraded to 4.25 and this is even worse. In the end I had to downgrade for 4.23.1 which works but the default hand controllers are missing a material but this is okay as I use my own models. I am at work at the moment but I could send you my C++ code for creating the headset and motion controllers ? Would you like it ?

How did you add the motion controllers? Are they dynamically added in the constructor in C++ or via the construction event in blueprints? Or did you just add them as components? Can you post how your hierarchy looks? I’m using motion controllers in 4.24 in a project that ultimately started in 4.21 and has been upgraded a few times. Did you check the MotionSource is set to the proper hand?

They are Actor blueprints that are spawned and created in the character class. Here is a screenshot of the code spawning and attaching them to the character:

Maybe it has something to do with spawning them as actor blueprints and attaching them vs. just creating the components for the pawn??? I remember there was a bug a while back with c++ generated motion controllers breaking but I forget exactly what it was.

Hey @ukflyb0y , thank you and I defiantly appreciate it. I just tried to upgrade to 4.23 but I’m still running into the same issue. If you dont mind posting that/sending it to me that would be very helpful. Thanks again.

[USER=“1384187”]Joe Wilcox WisE[/USER]

unfortunately I tried that, take a look at the post in the answer hub if you get a chance.

Just wanted to add, I’m willing to pay anyone 50$ to solve this issue. I’m desperate to get this working because its blocking my whole game.

Please help lol

anyone there?

Something strikes me as odd about your component hierarchy. There are two skeletal meshes, one above the motion controller and one under it. Which one of these is the hand? And what is the other one?

Hey @RotemS Thanks for the reply. I removed one of the Skeletal Meshes (myFirstPersonHandMesh and I made the myVrHandMesh the root), it was a remnant of an old tutorial. Unfortunately this doesn’t change anything and the problem still exists.

In the VR home screen I can see the controllers moving so I know its not a hardware issue. In my game however they just stay on the floor in the same spot. I can pull the trigger on the controller to grip/close the hand, but it does not move.

Keep in mind that any meshes must be under (child of) the motioncontroller component. If you make the hand mesh the root, it will not be attached to the controller.

I tried changing it up but still no luck:


Here is my updated code for the hand: BaseHand.cpp -


Hard to say, I think it should work? Does the default VR template work well for you? It will help you determine if it’s a problem with your code or a problem with your steam vr setup

The VR template does work however its not in C++ so I cant compare it against my project. I tried copying the input bindings from the template but that did not help either.

Perhaps its an issue with how I’m attaching it? Here is a screenshot:

Why not start the vr template on 4.23 works fine then copy paste what you have before there and use that vr pawn in template as it works perfectly

That wont work, My project is a C++ project and the VR template for 4.23 only comes in blueprint form.

Then recreate the template in c++, and if that works, you will find the differences vs your project. Alternatively, you can step through your project with a debugger and find out where it’s failing.

How can I create the template in C++? As far as I know the VR template is only available in blueprint form…