Download

Motion controller tracking seems to be lost the moment I add a static mesh to them?

Having an annoying issue trying to get a static mesh associated with my Vive controllers.

If I use the “Get valid tracked device IDs” node and then the “Get tracked device position and orientation” Node, and use the resulting location and rotation data to draw a debug box on tick, this works great. I Can see the boxes around the controllers and the tracking works great.

However, the moment I add a motion controller component to my pawn as advised, and attach a static mesh to it, I do not see the static meshes. I’ve tried adding billboards to the motion controller objects, and those display fine. Adding the static mesh back causes the billboards to not show up.

Any ideas?

Thanks

Using 4.11.2 and a Vive CV1.

Edit - So I’ve got it working but dont understand the fix. It seems my pawn doesn’t spawn unless I set the static meshes on the motion controllers to “no collision”. If I do that, it all works. The motion controllers are set to block all. Can anyone tell me why the hell that would fix it? Am I just being dense?

Its because right when your pawn spawns in the two motion controllers are intersecting each other. If you have collision enabled, you will cause your pawn to not spawn in.

Ah, ok, didn’t realise they both spawned at the same location initially. That makes sense. Thanks

omg thank you. i have been banging my head on this for a while now.

Major bug in the tutorial!!

What is the best way to work around this? Is it correct to disable collisions for the controller meshes? Won’t this affect overlaps and collisions with moveable objects later on? (I haven’t gotten that far yet :stuck_out_tongue:

Just noticed something else. The only change I made was to turn the controller static mesh collisions to No Collision. When I restarted, the camera spawned about 1m lower (through the floor). The controllers spawned ok. So I turned the colliisions back to BlockAllDynamic, and now the controllers spawn just fine. But the camera is still at the wrong height.

WHYYYYYYYYY

If you have actors which need to spawn and there’s a chance that they may overlap something, there is a dropdown where you can select “Spawn always, ignore overlaps” or something like that.