Motion Blur seems to suck pretty bad in UE4.

Here’s a simple a cube going relatively as fast as a race car. The amount of distortion and overlapping artifacts is too much, My actual model’s shadow gets so distorted that it’s beyond recognition.

I understand some of the limitations of post process motion blurs but this is too much, I never had this in Unity.

I tried playing around command lines and increasing quality, but the issues never changed.

I should mention that I also tried with both forward rendering MSAA and Temporal, same.


Agreed. One of the first things I do before I do anything else with every new project in UE4 is turn off motion blur. Have gotten so used to doing that I’d almost forgotten that if it actually worked well, I probably wouldn’t need to do that…