Motion blur even with Blur turned off

I have turned off motion blur in my level by adding a PostProcessVolume and turning off the motion blur there. However, when I changed the Pitch on my camera that motion causes blurring.

I have tried adding the following code to my camera:

	PostProcessSettings.MotionBlurAmount = 0;
	PostProcessSettings.MotionBlurMax = 0;
	PostProcessSettings.MotionBlurPerObjectSize = 0;

But that doesn’t seem to do anything.

Any ideas?

I’m still having this issue. Am I the only one? :confused:

Hi Meneleus,

I just wanted to make sure you checked this: Are the Motion Blur settings on the camera itself off? Is the motion blur only occurring with pitch changes of the camera?

I’m not 100% sure about anything anymore. I scrapped that project and started a new one based on the Strategy game sample and turning off the motionblur on the PostProcessing Volume seems to work correctly. I’m going to try to re-create the issue. The blur was present when panning the camera as well.

I’m not entirely sure what I did wrong, but I can’t recreate this issue. I think I may have had more than one floor model and perhaps that was causing the issue. >_< I’m just going to accept my own answer here and close this issue.

I’m guessing you had the camera component of your player overriding the post process volume’s settings. Resetting all the settings there or turning off Auto Activate should clear the issue.

Another possibility is another post process volume with a higher priority overriding the settings.