Montage not playing whole animation

I have a simple montage with a punch animation, which is 12 frames long. The montage has just the animation in it; no notifies or sections. The default preview shows the animation playing, but if I use play montage in the character blueprint, only 4 frames seem to play. If I instead use a play animation, the entire animation plays. Has anyone experienced this?

Most likely the way you are starting/stopping the montage is incorrect. Share a screenshot of the process for us to help debug.

Sure. Don’t mind the giant flashlight lol.

So, technically, the animation is a sword swing but same deal. Only a few frames play when the montage is called.

Here’s the blueprint. As you can see, I’ve set up a simple press 1 for this, 2 for that, etc. Both montage calls only play about 4 or 6 frames. If I press 1, which plays the animation directly, all frames play.

Ok. That’s wrong. Keypresses fire multiple times. You need to configure an input and use that.

The proper pathway would be a do once node with the release hooked to open it again.

However, it’s also noticable that your montage is messed up. The animation is factually only playing the “default” and not the other animation.

Check out the getting started youtube series with the 3 combo phunches for detailed walkthrough on how to get this going - including even the buttons.

Not true. There is no functional difference between a key pressed event and an action event. They only fire once.

I followed a tutorial on this method but it didn’t help.

I also haven’t noticed a difference in play back using the default or a custom slot. “Default” is just a name. But I did find a correlation with selecting previewed sections. In this case, I don’t have any sections. I can try adding them back though. However, another tutorial I followed didn’t and it worked fine for him. He also didn’t use a do once node.

I actually followed this tutorial on that: and ran into the issue I am having. I’ve tried different models, and different animations. So you’re right about something maybe being off in the setup.

Not true at all. There is a ton of difference. Particularly if one is an Axis Input.
The equivalent would be a keydown check happening during an on tick event.

On the montage, the image you posted. The very bottom “default” in green.
that’s the animation that will play.

To get the other animation to play, definitely delete the default track if it is empty - and it might just self correct.

You can also DoubleClick the animation, and it should automatically be appended to the montage.

regardless, the slot has nothing to do with the issue. The montage will either play or not play, for whatver the length it is instructed to play.
You could add multiple “default” one after the other to lengthen the montage. Or mix in different animations.

Or more precisely this one

Random suggestion for you. Whats the blend out value set to in the anim montage? Try setting it to 0 and see it plays the whole anim.

Might also be worth posting the anim blueprint so we can see how your slot node is being handled there.


The blend in/out values are default (0.25). I did try changing them to 0. Which does seem to help some.

I have a similar problem, playing anim sequence not playing the whole animation, even I use the simplest animation blueprint, the result is the same.

I had a similar issue; for me it was the blend in/out time on the animation montage. the animation was so short that a blend out of 0.25 was too heavy and cutting off part of the attack animation I was using. Open the Anim montage you are using and play with the blend in/out values and see if you no longer have the cut off!


I also just ran into this problem, the solution was as stated above by savagebeasty, I set the blend out time to 0 inside the anime montage(s) and seems to have alleviated the problem.

I think I figured out your issue. In the animation blueprint access your animgraph. Have your basic movement stat machine save a “cached pose”.

Then have your cached pose go into base pose on a “Layered blend per bone node”. Have a second instance of cached pose go into your “DefaultSlot” node, and the DefaultSlot
should plug into the layered blend per bone Blend Pose 0. Plug layered blend per bone into a seperate DefaultSlot, and complete the path to output pose.

Didn’t work for me. I have the same problem as the original guy.

I have the same problem as the topic author.
My Montage has 0.42second and 12 Frames but don’t play the whole animation and only call 6/12 frames. Everything worked when i change Anim rate scale to 0.5 or add some more Animation Sequence into this Montage. So sad …

I made video on how to fix it Unreal Engine 5/4 Play Montage Doesn't Play Whole Animation *FAST FIX* - YouTube

1 Like

Thanks so much, this fixed the issue for me!

1 Like

If you have UE5 just Open the Anim Montage and change the blend Mode in/out on Blend Option to Inertialization Then make the Blend Out Trigger to 0


Struggled with similar issue just about now and i can confirm that for short animations of 12 or less frames Blend In/Out options with default value of 0.25 almost compeatly cutting out whole animation. You have to open your montage and set Blend In/Out to atleast 0.1 or lower.

1 Like