ModuleManager.h Crashes with module 'IFoliageEditMode'

This has been happening to me since 4.11 first released. I’ve recently tried upgrading my project to 4.11 P7, and it still occurs. The call stack is useless in diagnosing the problem, it just tells me that the module has failed to load.

I can’t reproduce this in a blank project (ofc), but I haven’t messed around with anything module or engine-related, nor have I changed plugins or anything. I really don’t understand what could be causing the error, and this project is far too underway to simlyl start again or port content one bit at a time.

Log Here:
[link text][2]

It seems this problem is created by a Plugin conflict of some kind, or perhaps a missing dependency. I guess I disabled a lot of plugins early on in the project to either reduce build size or things that I’d just never use. Erasing all the entries for ‘Plugin’ in my .uproject file allowed me to load the project, but still doesn’t explain the issue.

Therefore, one of these plugins has an issue with the Foliage Edit tool I guess:

link text

Hey -

it sounds as though you were able to get the project working again. Without seeing the issue first hand I can’t say for certain what is causing it. If you have a broken version of the project still and can either post here or send me a PM on the forums with a link to download I can investigate further.


Hey ,

I posted this one on the forums too with a bit more info (Unreal Engine 4.11 Preview - Announcements - Epic Developer Community Forums). I posted the two versions of the .uproject file I used, the stripped-out one allowed me to load the project.

It might be that if you apply the same plugin section to a blank / c++ project that it may happen again. I’ll experiment with it and see what I can find out.

Hi ,

According to user ‘’ - this problem is caused by enabling the NetcodeUnitTest Plugin. Disabling it fixed the error for him apparently, but I suspect that means there is an issue with the Plugin itself?

I’ll test this later with my project to confirm.

Disable the NetcodeUnitTest Plugin, that one cause the error

(As I posted in the forum)