Modifying target tangent on beam module?

At the end of this beam tutorial, it shows example of how the beam would look if tangents of source and target are modified.
I was trying this out but could not achieve similar look. Mine looks like the target(and source) tangent only affect up to first interpolation point. Here are screenshots with interpolation points 10 and 3.
How can I make target tangent affects further out like the image on the tutorial?

Hi Pinepanda -

Are you adjusting the Source and Target’s Strength in addition to the Tangent?

Thank You

Eric Ketchum

Yes I modified strength as well but did not get expected behavior.

Are you adjusting the tangents in the graph editor? And are they set to AutoCurve?

I put 0 0 10 in tangent value in target module. Does it need to be a curve?

Hi Pinepanda -

Matt is correct, you will want to graph the tangent in the curve editor (click the Graph button on Source and Target) and add/adjust point through that editor to achieve you results. Auto Curve on your points will also smooth out the jagged look.

Thank You

Eric Ketchum

Hi Pinepanda -

Ok so I finally tracked down the tutorial maker and got us some answers. In the final image, they had set up a series of particles that were connected using the Target Method, Particle.

Sorry for the confusion and I will work on some clarity in that tutorial as well.

Thank You

Eric Ketchum

Using constant curve makes it animate the tangent over emitter time and it was not a tangent curve over the length of the beam.
This is with target strength 300 applied. Applying strong target strength may be what I need to do but there still is a big steep tangle at the end. How can I get rid of that?

Tangle moves around when I change interpolation point numbers

Thank you for looking into it Eric.
But do you have any idea on what I could do about tangle on beam?

Hi Pinepanda -

You should be able to adjust the Strength and Tangent settings to eliminate the tangle you are getting.

Thank You

Eric Ketchum