Models are transparent

Models are transparent from different place and when I shift the position of camera then models look normal. I want to know why is this happening.

That is because planes are only rendered from one side, you need to go into that object’s material and check the box that says two-sided, or render on both sides or something like that. just click on the main node in the graph, and that checkbox should be on the left.