Download

Mobile Project and Post Processing

Hey,

I have my project set up for mobile, and I was wondering how to get post processing effects? The Post Processing Volume doesn’t give any results, and I was wondering if it’s a different option for mobile projects. After reading things online I haven’t got a clear answer but I’m aware that post processing for mobile platforms is different to PC somehow.

On the Unreal documentation it says this, “Mobile postprocessing is implemented as a separate code path from PC/Console post processing”. Does this mean the post processing just isn’t visible in the editor?

Thanks
Sarah

Lot’s of Post-Process features aren’t available on Mobile sadly, there is a list somewhere but I can’t find it atm… it’s on the docs somewhere.

It also tends to vary depending on the device I’ve found, so it’s hard to say without specifics. I would recommend deploying to your device fairly often, even the mobile preview in editor isn’t always a reliable representation.

Thanks for your response. I have the list of post process features available (here) but I get no results at all when I change these values in my project that has mobile settings (in the editor). The post processing volume seems to have no visual affect at all on my project.

I haven’t been deploying it on a device because as far as I’m aware I have to pay a developer license to preview my game on my iPad.

Ah yeah for iOS you will, and you’ll need a Mac too. (Good guy Apple eh?)

You can temporarily test on Android though if you can get hold of a similar device. Also, there is a setting somewhere to completely disable mobile post process. Are you testing in Standalone / Mobile Preview / PIE?

EDIT: Ah yes, go to Project Settings -> Rendering -> Default Postprocessing Settings. I think the ‘Mobile’ setup turns them all off by default.

Oh cool, I’ll look into the Android development as I do have an android phone, it’s just quite old and slow so not sure if it’ll function right or even work!

Those settings were all disabled thank you! However, still don’t see a change? I’m testing in New Editor Window, but shouldn’t it just appear in the editor anyway? It does in normal projects. I also just tried it in Mobile Preview and it didn’t work (neither did my fog, is that a thing too?).

I know this is an old post , but im having exactly same non-display issue with postprocess at mobile
Also posted at the Answerhub
https://answers.unrealengine.com/questions/698535/mobile-hdr-not-working-is-a-compatibility-issue.html

Does anyone have any idea about this?
Thanks