Download

Mobile - Cannot Package, or Deploy to Device

Hey, I followed the ‘[Android Quick Start][1]’ guide and installed the Android Development Kit to my system.
I get errors when packaging the project, or deploying to my device via the launch from editor function.

Launch from Editor

Package Project - Android ATC

And I believe I linked the editor to the correct libraries

Things I have done to try remedy the problem
***** Verified the Engine
***** Installed Debug Icons
***** Disabled Antivirus
***** Deleted Intermediate, Config, and Saved folders
***** Installed Code Works to the same drive as Unreal Engine
***** Set UE4 to run as admin
***** Deploying as Development and Shipping

Does anyone have any ideas?

Cheers,

Please check in C:/NVPACK/android-sdk-windows/tools for android.bat. If it is not there you may have installed the wrong version of the Android SDK Tools. 25.2.3 is the last version which works.

I could locate the Andoid.bat in the “E:\1. Programs\NVPACK*android-sdk-windows\android-sdk-windows* ools” directory, is this correct?

Also, here is what I installed when prompted, does everything check out?

Should I be downloading any of these other packages, or is it dependent on my Android version?

Thank you so much…

This looks wrong. The upper left should read “CodeWorks for Android 1R6u1”.

oh god… The tutorial said 1R6, I did think this was wrong when doing this…
“Make sure that your are installing CodeWorks for Android 1R6 and then click the Next button.” - https://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/1/

Maybe this should be updated?

Yes please, wasted 3 hours because the docs are outdated :3

I ended up wasting a day fiddling around with it. The documentation shows that it was for 4.16, and shows ‘custom’ checked with custom components set to install. I ended up having to install an older version to get it to work.

Hello Guys, I’ve same problem , I’ve tested with 4.17 - 4.18 and also 4.19 all have same error “System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified”

Also i don’t have 1R6u1

yes, same problem over here…First - android.bat is not in NVPACK**android-sdk-windows*tools, it is located in NVPACK*android-sdk-windows\android-sdk-windows ools.

Maybe because of this double folder?

Why Epic have same errors in version from 4.12? I thin that 4.12 is last version that android development works without errors - just connect phone, and start launging in phone.

But now I lost about few days only to launch game on phone to test fps and other function.

I think I will deleate all this from my pc and start fishing fish :smiley:

It’s very annoying, the great UE4 has these kind of problems,
I’ve downloaded too many sdks and also I’ve checked Environment Variables , and they look good , I’ve update Android SDK Tools to 25.2.5 from android.bat but still showing 24.4.1_u1 in NVIDIA CodeWorks

Yes, very annoying, most because I need to test game in this phase but I have this problems a few days. Check every single problem from early posts - nothing helped out.

What is difference betwen chooser.exe and androidSDKmanager.exe (android.bat)?

I installed both API23 in chooser and android.bat - same problem. I deinstall API23 from android.bat, nothing changed.

I dont know why EPIC use this method to install API’s and arrange UE4 to work with android.
Android is today best market to us - amateur, to show what we can or what we cant. :smiley: :smiley:

You’re right, i don’t know why android bat and the chooser have different in installed or uninstalling result from skds ! I see same problem in my PC too.
I hope epic guys can help us.

@Chris Babcock

I’ve tried to install CodeWorks-1R7-windows_b104 but i lost launch ability in UE4 and i could not see my device anymore, so i had to back to 1R6

I tested today in UE 4.17 - and it works on android. If I open project in 4.19 - it still wont works on android.

I’ve tested in 4.12.5 , 4.15.3 , 4.16.3 , 4.17.2 , 4.18.3 and finally 4.19.1 , all return same ■■■■ error!
can you please screenshot from your codeworks , i want to see what is your sdks version, thanks

Okey, I will send you today after 20.00 pm, when I will be at home. :wink:

But finally I can work on my project.

Funny enough to stumble across this thread, I’m also encountering the same exact issues. There’s just no 1R6u1 option in my Codeworks installer, only 1R6! I feel like this is responsible for all of the later issues I’m seeing with deploying. Any help whatsoever would be extremely appreciated.

Here is screnshoot from Chooser.exe.
Tested again - dont works in 4.19, but in 4.17. works good :smiley:

Thank you for sharing @Tomislav0309! I confirmed that this does work in 4.17. It doesn’t work in 4.18, however, so I’m still looking for some way to get my project up and running again :frowning: