MMO Starter Kit

how to build server?

How to build the server is explained in the documentation :wink:

Sorry guys… Didn’t mean to start a Pro - Con Godaddy… just saying… for me… 6 bucks a month… and 24 voice support REALLY met my needs.

As to how to build the server… follow the Doc… don’t skip ANY steps in your hurry to see it work. I have lost DAYS by not reading… rereading… then reading the docs again. CodeSpartan has been VERY helpful… especially when I have let my impatience over ride my following the directions. He recenters me… and points me in the right direction. And then gently reminds me… “That’s in the documentation, if you need it.”

IE: The Launcher,… oh man… CS was helpful… and then gently referred me to the doc that answered my question… This is how it turned out.


Thank you CS for all your help.


You can host MySQL on the same server as the game, but for me personally, it’s just much easier to use the same MySQL hosting where I host websites. Webhosting providers are cheap and already have MySQL, phpmyadmin, ftp, etc installed, so you don’t have to install them yourself. Besides, the Softlayer VPS I’m using for the game server is the cheapest one, so I don’t want to put any additional load on it. Network bandwidth is not the bottleneck here.

Really nice work, good to see that any developer byhimself can nowdays create MMO with great graphics.
I have some ideas that i’ll mayby implement thanks to UE4 and your KIT.
Is there any point to migrate to postgersql and java as im more familiar these.
I just like them more. Postgersql has so many advanced features and java is fast and easy to read.

Suppose I wanted to use Gameservers. Can I have them to implement this? I used to host minecraft and atl servers. Too host under your own ip is retarded period. Can it be tranferrable?

What in gods name did i do?

lmao I don’t know how i managed this… but i have a clean copy of the starter kit. is there a file from the kit i can use to replace the file in game that causes this so i can go back to having a normal head?

Hi, I purchased your project recently but cant seem to open it. I downloaded it and built the UE 4.9.1 Source to run the project but it will not compile, either through the engine or visual studio.

Error 1 error C1083: Cannot open include file: ‘VaRestPluginPrivatePCH.h’: No such file or directory C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\Plugins\VaRest\Source\VaRestPlugin\Private\Parse\VaRestParseManager.cpp 3 1 CleanThirdPerson
Error 2 error C1083: Cannot open include file: ‘VaRestPluginPrivatePCH.h’: No such file or directory C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\Plugins\VaRest\Source\VaRestPlugin\Private\Json\VaRestJsonValue.cpp 3 1 CleanThirdPerson
Error 3 error C1083: Cannot open include file: ‘VaRestPluginPrivatePCH.h’: No such file or directory C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\Plugins\VaRest\Source\VaRestPlugin\Private\Json\VaRestJsonObject.cpp 3 1 CleanThirdPerson
Error 4 error C1083: Cannot open include file: ‘VaRestPluginPrivatePCH.h’: No such file or directory C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\Plugins\VaRest\Source\VaRestPlugin\Private\Json\VaRestRequestJSON.cpp 3 1 CleanThirdPerson
Error 5 error : Failed to produce item: C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\Binaries\Win64\CleanThirdPersonServer.exe C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\Intermediate\ProjectFiles\ERROR CleanThirdPerson
Error 6 error MSB3073: The command “C:\Users\Levi\UnrealEngine-release\Engine\Build\BatchFiles\Build.bat CleanThirdPersonServer Win64 Development “C:\Users\Levi\Desktop\Forgotten Races Project\Client\Client Sources\MMOStarterKit-1.3\CleanThirdPerson.uproject” -waitmutex” exited with code -1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 38 5 CleanThirdPerson

this is the error i am getting from visual studio when i try to compile it manually, I have checked the varest plugin folder all dependencies and all #included files are accounted for including the file the error says is missing, can anyone help.

EDIT: Solved, downloaded clean copy of latest varest plugin and replaced only the files that were already in the project folder. Thank you for this amazing project CodeSpartan, and for the help with my issue.

You probably just have to set the rotation and location of the Head mesh to zero in “ModularPlayerCharacter”

Is this still alive? It is updated to 4.9. It should be. I am considering purchasing it and I hope it still is being developed and supported.
I downloaded the launcher and it is stuck in “Deleting temp files” and PLAY button is disabled. I started it as Admin. But still not able to test it…

EDIT: After seing the dates and reading previous posts I am guessing it is being fixed for the 4.9.1


4.9.2 was just released!

You can host Unreal dedicated servers on any VPS, as well as on your own home PC. Personally, I use Softlayer. I chose it because they have 24/7 chat support and Path of Exile hosts there :slight_smile:

Answered you in PM.

This is very much alive and I release updates simultaneously with the official builds. The last update was for 4.9, so the next one will be for 4.10. The hotfixes (4.9.1, 4.9.2) are usually tiny and don’t require any extra updates to work with the kit.

I suppose you could rewrite the php scripts, but it’ll take some time. Personally, if they were in a language I’m not familiar with (for me it’s python), I’d still leave them as is and learn to read them. There’s no complex stuff there. If you do choose to rewrite them, make sure you find a good alternative to php 5 password hashing in your language of choice.

Aparently I was experiencing a weird Win7 Professional (64) + 4K monitor scaling issue that was easily resolved by fantastic supportive CodeSpartan over a quick Team Viewer session.

I just installed 4.9.2 and initial tests seem to be working just fine too!

Amazing to be able to work on gameplay and worldbuilding while the hard part (for me) networking is taken care of.

Thanks again CodeSpartan!

Any way to get it for free? Would do nearly anything. I’m in learning phase and can’t efford 95$

I did not really find the Demo so useful and haven’t even looked at it for quite a while. I just started by digging around in the actual project and learning how its blueprints work, especially the character and JsonRequests and UI widget blueprints. The main thing that takes some understanding is what’s going on between the JsonRequests blueprint, the PHP files, and the .sql database. Apart from cosmetic art changes, you can’t add or modify much until you figure out how those are working together.

If you want to know if the product is worth buying, look at the youtube video. I think it is very nice.

Sonny, I am sorry to hear that the money for the kit is difficult to come by. I to found it to be a stretch to buy the kit. But, I looked at it three ways before I got the kit.

  1. All of the time, and money it would save me. I don’t program, and I have little artistic skills. But, I have a dream. After looking at what the MMO kit did for me, and how much it would save me… I was taking bids from programmers to build from scratch what the kit mostly provided. And I saw the bids… vs the kit price. I had been saving money for those bids. And had an Auto bill come due that took a lot of it. But, the kit was going to save me hundreds of dollars to accomplish what I was trying to do… All I have to do it pay to have pieces modded now.

  2. I looked at what I was trying to do. (Build a game for my Kids, and their friends to be able to log into and play.) Because of the time it took me to save the money and let me start taking bids, I had some idea of what my dream was going to cost. I still find the parts that I need to accomplish what I want to do is going to cost money and I had to look at what that cost is and decide if my dream is worth the money I spent.

  3. Last thing, after I spent the money, I found that not only can I log into a game, and begin to mod the terrain and see my dream start to evolve, and see my kids excitement grow, and hear them talk to their friends about what Dad is doing. (I wish you could hear dinner time at my place. When the kids come over, they have questions, and we talk about ideas for the game. ) And, I found that Codespartan has been 1,000% above and beyond in helping me learn the pieces I have about the kit. NO extra money, his/her (Not sure if Code is male or female, I call him bubba in chat.) time has been spent in helping me even after the I had purchased his work.

Codespartan has even said earlier that anyone could build what he has done by studying the VArest by Unfa (I think is the name, Unfa’s name is in the credits if you care.)

My advice comes as follows:

Easy path: Save your money. Buy the kit. Keep learning UE 4 as you save.

More difficult path: Read this thread… gather the resources that have been talked about, and teach yourself to create something like the kit.

Both have advantages. But, to IMHO: If you can’t afford the kit… how do you see making a game for less than 95 dollars? Complaining about something “not being free” is really not fair. You have a dream, YOU need to reach for it, not ask for others to hand you your dream for nothing.

ReReading this it sounds harsher than I intend. It is not my intent to hammer you. But, hopefully, you will see I am just sharing my journey, and hope you might look at your journey, and see what I am trying to drive at.


–Edit: My fault, I had a capital character in my URL from when I moved my PHP over to SiteGround. Sorry –

First of all, awesome kit, you have saved me valuable time!

I am having an issue with user registration. When I go to register, I enter the required information and click register, it just clears out my password and does nothing. Taking a look at the User table, there is nothing there. If I manually create an entry in this table, and then try to register a user with the same name it give ma an error, so I know it can read from the DB. I am guessing there is an issue with writing to the DB for some reason. I know the account I am using has write access and I can log in with navicat and write to the tables with it.

Sort of stumped. I have searched this post and cant find/don’t see/missed anyone who has had this problem, sorry if I missed a post on this.

Anyone have any ideas?

DB hosted on network solutions MySQL
PHP hosted on SiteGround Current PHP version:


Rob, I have run into that a number of times… as a matter of fact… I have had so many troubles… (All of my own creation… no KIT issues.) I don’t remember the fix…

So, I would start off with my first test… IN setting up the database section of the tut…

Check this… (Step 5)


If it says {“status”:“Login information is incorrect. Check your username and password.”} this means the script is working fine, good job!

If it says Connection failed or Access denied, double-check the database connection info that you filled in step 2 **… I believe I found it is case sensitive … so, I had issues with it.

**If that idea doesn’t pan out… maybe Code Spartan or someone else can chip in.

Just a quick question what if I’m wanting to setup a moba with your mmo starter kit? Will that work? As I will be wanting to use a login/register system with stat saving so really your kid will work perfectly as far as I can see, setup a auto-find lobby and limit team sizes etc.

Also would you be able to keep your first post up-to-date in terms of the tests you have ran like amount of resources used on your real world stress test, just thinking so we dont have to search for this stuff or post questions that have already been answered in here :slight_smile:

Glad you figured it out. :slight_smile: You can also add me on Skype (CodeSpartan) for quicker support.

For a MOBA you will probably want to dynamically launch and close server instances. I have instancing planned but it’s not in the kit at the moment. You could modify the C# socket chat server source code (that is included with the kit) to auto-launch instances. The FAQ section of the user guide has a little more info.

The first post has a link to the stress test info. Also, there’s a FAQ section in the user guide, and it has gotten really huge, it wouldn’t make sense to add it all to the first post :slight_smile: