Mixamo Mesh does not want to SetSimulatePhysics

I am using a line trace and hitting the mesh I am also setting the capsule component to have no collision and I am setting the mesh to query and physics. The mesh itself just stands completely (Stays in Idle Animation) still with no movement. UPDATE:
I set physics enabled in the Editor and the the editor says that Collision Enabled is incompatible.
I changed the enabled collision physics to query and physics and it worked. But when I call the change in C++ it doesn’t work.


//The equivalent of ticking both boxes.


I just realized the function itself wasn’t calling. I have to always remember to put UE_LOGS().