Missing shadow with static spot light

I have got a single static spot light on the scene. When I build the light my shadows are gone. I changed it to stationary but then I get weird shadows. Hope someone’s got the solution. Thanks in advance.

My light source (Static light results):

Missing Shadows (Static light results):

Light settings:



World lightmass settings:

Lightmap density:

Stationary light with the same settings:

Problem has been solved. Since I contain my static meshes into blueprints I forgot to set them as static. Now I’ve got desirable shadow and light.

The weird shadows from stationary lighting could be a result of shadow filter sharpen being at above 0. Though it’s most likely a combination of that and something else if it’s the case. I was modifying a template level, set shadow filter sharpen to any value above 0, and got weird, curvy shadows for almost every mesh.