Missing Mesh Distance Fields (for shadowing)

I am having some issues generating Distance Field shadows for my meshes.
Looking at the DFAO, it seems fine. The MDF visualizer shows some meshes missing.
I am fairly new to UE, so it would be nice with a few guidelines. Maybe it could clarify why
this is happening.
I have created blueprint assets from static meshes with shaders, and duplicated these meshes (is there another more efficient way?)

Here is an attached image to show the issue I am having.


Any info would be appreciated.


Are the builings with missing DF scaled non uniformly by any chance?

First you need to increase Distance Field Resolution Scale of those half and non-visible meshes in static mesh editor > LOD0 > Build Settings. And then make sure Cascaded shadow map distance is set to 0. If you still see issues with shadows the size of the buildings may be too large for this, as there is a size limit for meshes to cast proper ray traced distance field shadows, as far as i know.

Btw, here’s the documentation: Distance Field Soft Shadows | Unreal Engine Documentation

Thanks guys!

I guess I was just a bit confused as to why the AO was ok and not the shadows, but found this in the manual.
(the bottom right image was csm dist. at 0, Jacky)

“Distance field fidelity has a large impact on shadow accuracy, more so than Distance Field AO”

Increasing the rez to 3 fixed it. Still have some problems getting AO to be stable though.

Much appreciated!