Missing hair on Packaged Metahumans on UE5 Preview 1

Hi everyone

So after updating my project from EA2 to Preview (using the latest commit as well from 5.0 on Github), when i package the game, all the hair in my metahuman character dissapears. However, if i play in the editor (on Standalone Game mode) the hair is there.


This is what i have in the log when running the packaged game.

Everything worked fine in the EA2 version. I tested this both in the launcher engine version and the latest 5.0 git version (up to this date).

Can anyone help?
Thanks in advance

1 Like

Better look at the errors on the packaged build:

same problem

Even with a new Metahuman (reimporting a new one), the problem still remains.

also getting this, hopefully will get fixed soon

Having the same issue both in Preview 1 and Preview 2. Was working fine on Early Access 2.

Retried on latest commit from the UE5 branch and it is still broken.

Even tried a project from scratch and i am having the same result, don’t really know what to do to fix it.

We managed to find a solution. Since there is the possibility of differences of scale between the components of metahuman (Body, Face, etc), Hair, fuzz, eylashes and any kind of groom attached are hierarchy binded to their parents. So you have to change the Bounds Scale of the Face (or body, if there is any groom attached to it) at blueprint, if you do it at scene, you’ll have to overwrite the blueprint before save, or else it will lost the setup.

Here we changed from 1 to 100, it worked perfeclty, we were facing this problem using the cinematic cameras + sequencer + render queue. So It’s possible that it is the same problem at play / rendering / packing time.

Please let me know if it works for you guys
Hope It was helpful!


Make sure the groom plugin is added to the uproject, i.e make sure it has this :

“Name”: “HairStrands”,
“Enabled”: true


On my end, the post from fredrik_lonn fixed the issue! Thanks!

Perfect thank you!

Hi. Confirming that fredrik_lonn suggestion did the trick.

If that helps, I saw the issue over Linux (From Ubuntu 21 to 22)

Is someone able to explain how to do this please? I’m stupid

Ok never mind, I figured it out.
For those that find this and don’t know how. Right click on your .uproject file and open with note pad. You can edit from here and add the above lines.
Worked for me so thanks heaps.

1 Like

Thanks , It’s working.

I have the same problem. But where do I change the HairStrands option?

As of UE 5.0.3, this is still an issue, and manually adding this package dependency fixed the problem for me.

Strange that it isn’t automatically added along with the other plugins that get auto-added when you use a metahuman from bridge

enabling the “Alembic Groom Importer” should be sufficient in 5.0.3

1 Like

thank you for the solution, could you please help me out with implementing it?

Initially I’ve pasted the code into the file, which made it not readably by Unreal. Then i typed the things manually and the file is visible for Unreal now, but hair still doesn’t render.

Maybe there are some other necessary steps that i might have missed ? I have skin cache option activated in the project’s settings and the necessary two groom plugins installed as well.

Thank you. :clap: It works for me.