Download

Metallic Textures

So… I am very disappointed with the fact that I can’t fix this. First things first, I recently deleted Xcode from my computer to free up space. After it glitched up my UE4 processes, I downloaded it back. Now, whenever I go into UE4 and load up any game, It tells me this, ‘Xcode on this Mac cannot be used for Metal shader compilation. Falling back to runtime compiled text shaders, which are slower. Please install Xcode 8.3.x for best performance’. I did redownload Xcode. I downloaded Xcode 8.3.3 which, as it says, is compatible. However, I still get the message. Not only that, but in the actual game, all metallic and gloss parts of a texture are canceled out and won’t load. This is very frustrating as I have tried to fix it many times without success. And if this helps, when I run the game it says that texture streaming pools are over 150mb (On Average). Thanks in advance for all answers!

Metal is a low-level graphics API for Mac(like DirectX on Windows), it’s not referring to the metallic aspects of materials

You might need to reinstall UE4 to get it to reference Xcode again

So like, keep my folders that store my uprojects and just completely delete Unreal Engine and redownload from the website?

Go into the Epic Games Launcher and remove your installations of UE4, and then redownload through the launcher.

Heyy! So I tried this out and It didn’t work, unfortunately. I would like to thank you for your help though!