Download

Metahuman eye translucency causing black blobs

I am trying to use translucency for some glass in my scene and it’s causing the eyes to have black blobs in them, I’ve tracked it down to the M_Eye_Occlusion material but I have no idea how to fix the issue, if I drop another transparent material in the the M_Eye_Occlusion slot then I can fix this but lose some of the eye detail around the edges. Does anyone know how to fix this? Thanks :v:

2 Likes

Same here. When I activate Ray tracing translucency (since I need it in scene), there are dark blobs in eyes and eyelashes (card one that I don’t need at all).
Seems like it was a common issue with eye shader, written that it was fixed in 4.26.2 exacly

How do we correct this issue then?
Thanks

1 Like

+1

Raytracing translucency seemed to have some bugginess on the Car Configurator model as well, albeit different (didn’t look there was any material at all)

The issue with Metahumans with RT translucency is coming from eyeocclusion mesh and eyelashes mesh. Can anyone help please how we need to modify the eyeocclusion material in order to work? And how to remove eyelashes cards? I already assigned invis material to eyelashes but the artifacts are still there. I’m interested only in LOD0, which should have groom eyelashes
Thanks

Turn translucency refraction off in post process under ray tracing translucency to stop eye lash shadows. As for the black in the eyes I’m still struggling with that. You might also need to turn on translucency. Let me know if that fixed your shadow issue?

Yeah, but I exactly need the RT refraction in my scene. Can’t I just really hide these card eyelashes? I don’t need them, since I’m using the groom eyelashes. But assigning invisible material doesn’t fix the issue

The black blobs issue seems to appear as soon as raytracing is enabled in the project settings. The eyes go black if there isn’t any direct light hitting on it and also if I go far the eyes transition to what it’s supposed to look like in the first place, but when I move closer it slowly fades to black , I see this is an issue with the eye occlusion shader. This issue happens mainly when using an HDri backdrop or a skylight. Is someone else facing the same issue?

Test_2 Test_3

I got the same probleme. I don’t think it come from the eye occlusion mesh but rather from the eye shader. I have remove the eye occlusion shader and the eye are still black with raytracing enabled.
It look like the eye is not working with the hdri backdrop when raytracing is enabled.

Go to blueprint - on the left hand side under components double click on “face” - On the right hand side in the materials tab double click on “Element 5” - On the right hand side under General double click “Parent” - On the left hand side under Material change the blend mode to “Additive”. Hope this helps :v:

2 Likes

this worked thanks!