Metahuman - Bridge - Maya integration issues

Hello,
I’m having some issues here when trying to export Metahuman to Maya. I didn’t have these problems before, but after formatting and reinstalling the system, the problems appeared.

I’ve installed two versions of Maya here - 2022 and 2023. Everything is running fine, PyMel was installed for both versions, all the paths standard, so shouldn’t have any issues.

I’ve installed Bridge and installed the plugin for Maya integration. Downloaded the Metahuman assets in the same folders/structures as before the formatting, so the .dna files would be in the same place.
When I try to open a saved scene with the Metahuman character, errors regarding the plugin prevents the rig to work properly. The message in script editor is as follows:

RuntimeError: file <maya console> line 1: Plug-in, "embeddedRL4", was not found on MAYA_PLUG_IN_PATH.

I assume the plugin was not installed properly, or it was installed in a place where the environment variable was not set.

When trying to export the Metahuman character from Bridge to Maya, errors happen in Bridge. They are:

Error: Could not send data over port 13291

The bridge.log showed the following issues:

{"level":"info","message":"app-progress-hide","timestamp":"2022-11-08T17:21:54.341Z"}
{"assetIds":["7plqHZQV"],"level":"info","message":"exporting assets","timestamp":"2022-11-08T17:22:06.147Z"}
{"level":"info","message":"Sending data over socket. Host = 127.0.0.1, Port = 13291","timestamp":"2022-11-08T17:22:06.156Z"}
{"level":"error","message":"connect ECONNREFUSED 127.0.0.1:13291","timestamp":"2022-11-08T17:22:08.454Z"}
{"level":"error","message":"Could not export assets. Please check log for details","timestamp":"2022-11-08T17:22:08.457Z"}
{"level":"info","message":"app-progress-hide","timestamp":"2022-11-08T17:22:08.459Z"}

Is there any solution for the problem? Is there a manual workaround to install the plugin, or a way to make it work properly?

Thank you!

Check your firewall. Seems the connection is being actively refused.

You may need to add a exception for 127.0.0.1, Port = 13291 in your firewall. (If i remember correct its on udp port)

I’m also not sure if it will run on 127.0.0.1 (local host). You may need to set a specific IP for your network card

Hey! Thank you for the answer.

Unfortunately, the solution didn’t work. I added the exception, but with no success…
The connection might be getting refused because the app is not being able to connect with the plugin or something…

Did you unblock inbound and outgoing data? It’s a 2 way connection.

Yes… no deal…
I Tried to put also a TCP exception, no way…
Something is very wrong…

There is the possibility that something else is using this port, but I have no idea what it is or how it’s possible

Here is the Maya 2023 script editor messages when loading the plugin for the first time:

Quixel Bridge Plugin started successfully.
# DHI.modules.maya.util : Preparing paths and loading DHI Plugins
# DHI.modules.maya.util : Running on Windows 
Importing DHI external libraries
# DHI.modules.maya.util : Running Maya version 2017
# DHI.modules.maya.util : Fetching libraries from folder C:/Megascans/support/plugins/maya/6.9/MSLiveLink/DHI/lib/Windows/python2
['C:/Users/XXXXX/Documents/maya/2023/scripts/site-packages', 'C:\\Windows\\system32', 'C:\\Program Files\\Autodesk\\Maya2023\\plug-ins\\ATF\\scripts', 'C:\\Program Files\\Autodesk\\Bifrost\\Maya2023\\2.5.1.0\\bifrost\\scripts', 'C:\\Program Files\\Common Files\\Autodesk\\ApplicationPlugins\\bifrost\\Contents\\scripts', 'C:\\Program Files\\Autodesk\\Maya2023\\plug-ins\\MASH\\scripts', 'C:\\Program Files\\Autodesk\\MayaUSD\\Maya2023\\0.19.0\\mayausd\\MayaUSD\\plugin\\adsk\\scripts', 'C:\\Program Files\\Autodesk\\MayaUSD\\Maya2023\\0.19.0\\mayausd\\MayaUSD\\lib\\scripts', 'C:\\Megascans\\support\\plugins\\maya\\6.9\\MSLiveLink', 'C:\\ProgramData\\Thinkbox\\Deadline10\\submitters\\Maya\\scripts', 'C:\\Program Files\\Autodesk\\Maya2023\\plug-ins\\fbx\\scripts', 'C:\\Program Files\\Autodesk\\Maya2023\\plug-ins\\camd\\scripts', 'C:\\Program Files\\Autodesk\\Arnold\\maya2023\\scripts', 'C:\\Program Files\\Allegorithmic\\Adobe Substance 3D for Maya\\2023\\scripts', 'C:\\Program Files\\Autodesk\\Maya2023\\plug-ins\\sweep\\scripts', 'C:\\Program Files\\Autodesk\\Bifrost\\Maya2023\\2.5.1.0\\vnn\\scripts', 'C:\\Program Files\\Autodesk\\Maya2023\\plug-ins\\xgen\\scripts', 'C:\\Program Files\\Autodesk\\Bifrost\\Maya2023\\2.5.1.0\\bifrost\\python\\site-packages', 'C:\\Program Files\\Autodesk\\MayaUSD\\Maya2023\\0.19.0\\mayausd\\MayaUSD\\lib\\python', 'C:\\Program Files\\Autodesk\\MayaUSD\\Maya2023\\0.19.0\\mayausd\\USD\\lib\\python', 'C:\\Program Files\\Autodesk\\Maya2023\\bin\\python39.zip', 'C:\\Program Files\\Autodesk\\Maya2023\\Python\\DLLs', 'C:\\Program Files\\Autodesk\\Maya2023\\Python\\lib', 'C:\\Program Files\\Autodesk\\Maya2023\\bin', 'C:\\Program Files\\Autodesk\\Maya2023\\Python', 'C:\\Program Files\\Autodesk\\Maya2023\\Python\\lib\\site-packages', 'C:\\Program Files\\Autodesk\\Maya2023\\bin\\python39.zip\\lib-tk', 'C:/Users/XXXXX/Documents/maya/2023/prefs/scripts', 'C:/Users/XXXXX/Documents/maya/2023/scripts', 'C:/Users/XXXXX/Documents/maya/scripts', '..', 'C:\\Megascans\\support\\plugins\\maya\\6.9\\MSLiveLink\\Megascans\\RequestLibrary', '..', 'C:\\Megascans\\support\\plugins\\maya\\6.9\\MSLiveLink\\DHI\\pose_wrangler', 'C:\\Megascans\\support\\plugins\\maya\\6.9\\MSLiveLink\\DHI', 'C:/Megascans/support/plugins/maya/6.9/MSLiveLink/DHI/lib/Windows/python2']
# DHI.modules.maya.util : Running on Windows 
# modules.maya.util : Running Maya version 2017
Loading plugin:  C:/Megascans/support/plugins/maya/6.9/MSLiveLink/DHI/plugins/Windows/2017/embeddedRL4.mll
Error loading plugin embeddedRL4
Loading plugin:  C:/Megascans/support/plugins/maya/6.9/MSLiveLink/DHI/plugins/Windows/2017/MayaUE4RBFPlugin2017.mll
Error loading plugin MayaUE4RBFPlugin2017
Loading plugin:  C:/Megascans/support/plugins/maya/6.9/MSLiveLink/DHI/plugins/Windows/2017/MayaUERBFPlugin.mll
Error loading plugin MayaUERBFPlugin
saveShelf Deadline "C:/Users/XXXXX/Documents/maya/2023/prefs/shelves/shelf_Deadline";
// 1
saveShelf MSPlugin "C:/Users/XXXXX/Documents/maya/2023/prefs/shelves/shelf_MSPlugin";
// 1
Quixel Bridge Plugin started successfully.

From Maya 2022 there is no message at all. Looks like the plugin weren’t installed

1 Like

Ok. It’s being a struggle, but I’ve finally figured it out and solved it.

If you’ve being having this issue, please read the bullet points for understanding and to solve it:

1- Bridge won’t install plugins in the proper manner if you have 2 different versions of Maya installed. Besides, even though MS is compatible with Maya 2023, Metahuman plugin is not. You can tell it because inside the support plugins folder, there is no 2023 Maya version plugin. I couldn’t make it work, not even when trying to hardwire the plugin. It won’t work. Period. Maya 2022 will work though.
2- The Bridge app Error “Could not send data over port 13291” is pretty deceiving. It doesn’t mean the connection is simply refused. It means Bridge could not “bridge” exchanges between Bridge and Maya, because there is something wrong with the plugin. The .log file also does not tell you any clue of that.
3- Even though you have PyMel installed, you should make sure it is set within the Environment Variables. And not only that, but you might also need to put the MegaScans plugin path into it too. The easiest way to do so is setting maya.env (if you’re using Windows, the standard path is C:\Users\USERNAME\Documents\maya\MAYAVERSION). You open it with notepad and put there:

MAYA_PLUG_IN_PATH = C:\Megascans\support\plugins\maya\6.9\MSLiveLink
PATH = C:\Program Files\Autodesk\Maya2022\Python37\Scripts
PYTHONPATH = C:\Program Files\Autodesk\Maya2022\Python37\Scripts

If you want to make sure everything is running well with PyMel, please follow this link here: https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2022/ENU/Maya-Scripting/files/GUID-2AA5EFCE-53B1-46A0-8E43-4CD0B2C72FB4-htm.html#:~:text=For%20Maya%202022%2C%20PyMEL%201.2,with%20the%20%2D%2Duser%20option.

You see, I’m an artist. I’m not a programmer or something. I had to headbutt a lot to understand how things work. And because of that, I have some suggestions for Quixel and Epic developers.
Please do a more comprehensive plugin installation. I know one-click installs are very, very user friendly, but when something goes wrong, you’re lost. We should have a list of Maya versions in the installer and choose which ones you want the plugin to be installed. You should put a box for the user to choose if he wants the installer to change the env. variables. And, if you have an unsupported version of Maya, the plugin should tell you. It’s not that hard, guys.

3 Likes

I have been trying to get a metahuman into Maya 2023. My firewalls are fine and I only have one version of Maya installed. I have the Maya pluginas well, but the options to export it just are not there. I have tried Bridge as a standalone and also from in UE5 (see image), but nothing seems to allow the downloaded Metahuman to be exported.

All I see when I open bridge from inside UE5 (with Maya open) is a megascans option. I dont have the ability to install a previous version of Maya, so it doesnt look like I will be able to use this as intended until there is some form of update or find a way to make it happen.

I really did not expect Epic to be so lapse in their provision of tools.

Unless its something I am not doing, but I have read a few threads and looked at various videos claiming they know how to do it, but they are usually old versions of Bridge and earlier versions of Maya.

If there is a proper, well documented and helpful metjhod to achieve what I want to do, I would appreciate the pointer. The docs do not seem up to date either, so its a maze of confusion and unhelpful content currently.

image

1 Like

Thank you so much for this. Been searching for this solution for months and this worked!

Hello Rafael, thank you for your contribution. Your input was very helpful in figuring out and solving the bug. Here is a brief summary of the steps I took that worked for me:

  1. Firstly, I encountered the same port error message on the Bridge, “could not send data over port 13291”. To fix this, I went to the “Edit > Settings” menu and changed the configuration of the API Port to 13291. This resolved the export problem in the Bridge, even though nothing was displayed in Maya yet.
  2. Next, I realized that the MegaScan plugin was not appearing in the editor shelf in Maya. To solve this, I had to manually install PyMel, even though I had initially selected this option during the Maya installation. Here are the steps I followed for Windows OS:
  • Make sure Maya is closed
  • Run the cmd window as an administrator
  • In the CMD Go to the Maya installation folder where the mayapy.exe file is located (in this case, it would be located at C:\Program Files\Autodesk\Maya2023\bin). If you installed the application on another disk, you must first change the location (with the D: command for example, if it is disk D.) C:\Windows.… > cd C:\Program Files\Autodesk\Maya2023\bin
  • Run the following command to install PyMel: mayapy -m pip install pymel
    C:\Program Files\Autodesk\Maya2023\bin> mayapy -m pip install pymel
    Wait a few until it throws the message “Successfully installed pymel-#.#.#”
  • Open Maya and it should load the plugin successfully (if not, check the environment variables previously mentioned by Rafael in point 3).
  • Finally, try to perform the export again from Bridge to Maya (remember to change the export target to Maya) and now it should be successful.

I hope this helps anyone who might be experiencing similar issues. Thank you again. Here’s a link to the PyMel installing guide for further reference: https://help.autodesk.com/view/MAYAUL/2024/ENU/?guid=GUID-2AA5EFCE-53B1-46A0-8E43-4CD0B2C72FB4

8 Likes

i have the same problem driving me crazy … Did you find any solution for UE 5 and last version of maya ?

Thank you so much brother!!

Hi I’ve been having issues using the metahuman plugin while exporting from bridge. Maya 2022 and 2023 both crash instantly.
I’m not having this issue while exporting other non metahuman assets so its definitely plugin related.
I managed to get a readout from the script editor before the crash,

Found import data, importing…
Bridge logging exception [WinError 10061] No connection could be made because the target machine actively refused it
Metabase Exception :

Would appreciate any help in this regard!

So I am unable to get the Bridge logging exception error anymore, though I still have the crashing issue.
If I use maya plugin 7.0 (instead of 7.1.5) it doesn’t crash immediately but the dialog to load the metahuman comes up, and once
“DHI.modules.maya.util : opening new file…” shows up it crashes. I’ve attached an image below.
When I use maya plugin 7.1.5 it crashes immdiately after “Analytics sent”

I’ve made some progress on this issue.
I had a friend try to reproduce it on his end and he had no errors.
So he sent me the maya file and when I linked it to the _rl.dna file maya crashed.
It seems that _rl.dna file is responsible for the crash and its only happening for my computer.
Would it have to do with system requirments?
These are my computer specs,
OS: Windows 10 Pro
MB: GA-880GA-UD3H
processor: AMD Phenom II X6 1090T
Memory: 16384MB
Graphics: GTX 1050ti
My friends pc is much stronger, his has Windows 11, an intel processor and a GTX 3080 nvidia graphics card

worked thank you so much

It is so ridiculous that the plugin Maya LiveLink has issues! Bro, Meta needs to hire you as Dev support lol, thanks a million!!

Thanks for your guiding. I found when MSLiveLink plugin leave quixel library, Maya will throw lots of error after export. Ex. “XXX no attrbute named message”. Maya.env file is not work for me. My Maya can not load pugin when plugin path exist non-english character. I did this to solve problem. Now It worked on Maya2022 and Maya 2023.

  1. uninstall quixe bridge and delete maya plugins file
    maya plugins file path :
C:\Users\username\Documents\maya\modules\quixel.mod
...\quixel library\support\plugins
  1. reinstall quixel bridge and delete non-english character in library file path.
    3.In quixel bridge, open Edit-> settings, fill new library path, and change API Port to 13291.
    4.Install plugin and change metahuman download setting follow:
    https://dev.epicgames.com/documentation/en-US/metahuman/exporting-metahumans-to-maya
    5.open C:\Users\username\Documents\maya\modules\quixel.mod with txt editor.
    makesure all path is right and all directory name is english character.
    6.Then open Maya, Then will load plugin and export normally.

Legend!

Thanks a lot Rafael! Cheers!