Metahuman animations stretched when using Movie Render Que

Hi all,

I’m having a problem with weird stretching using Metahumans and Movie Render Que. The animations I’m using are done with motion capture and retargeted to Metahumans, they work perfectly fine in runtime and in sequencer (although sometimes the heads are not moving with the rest of the animation, could use some help with that also!)

When I try to render the sequences out with Movie Render Que, the whole torso of the character gets stretched into the origin of the actor (not using root motion). I’ll attach an image below to help visualize the problem. The problem persists with both UE 4.27 and 5.0.2, with deferred rendering and path tracing and with root motion enabled or disabled. I’ve double checked that the retargeting options are correct in the skeleton. Like mentioned above, this only happens when rendering the sequence, not when playing it in editor or in game. When not using an animation asset but rather posing the character into a static position with control rig this doesn’t happen, as you can see from the other picture. I’ve tried to bake the animations to control rig but that didn’t help.

If anyone has experienced this and found a solution, or you have a hunch what might be causing this please let me know!

1 Like