Download

Meshes turn completely black after building lighting.

Hi all.
I made sure all my UVs are correct and on the right channel when exporting to FBX, and before putting them in the actual scene, I test build the lighting in a separate project to see if I have the UVs correct.


And it looks all good.

But as soon as I put them in the actual project I want them in. This happens:
Capture02.PNG

What’s going on? The light map resolutions are all 512, and the UVs are showing that it’s all correct.

Check in your 3d package - odds are your normals are faceing inward.

I don’t know why, but this happened to me after I switched the light from Stationary to Static.
If that’s not it try this:

Not sure what you mean, but the normals are all correctly facing outward. The first image shows that it builds fine. It seems like it’s only in this particular scene it’s turning black.

When you say correct, I’m assuming you mean there are no overlapping faces in your lightmap UVs?

Also make sure your lightmap UV’s are assigned to the correct channel. By default UE4 will try to generate an additional lightmap UV channel which it will assign for the lightmaps. The option to turn that off is in the Import window.

So I was having much difficulty with this as well.

Two things you’ll want to check:

  1. The material’s AO input: if you are using a clamp, lerp, or even a simple scalar, check to make sure it’s not set to 0. It will cause your meshes with the material to be read as completely shaded by the AO.

  2. If your material relies heavily on metalness, you’ll want to use a reflection capture actor. Box or sphere is fine. Otherwise if you’re using static lights then the information won’t be stored anywhere after the lighting has been baked.

Yes the UVs are correctly flattened, and on channel 1
479a26a759b30228d204f5d8c6557024f3598afb.png

The material is just a white color with roughness of 0. Nothing else.