Download

Mesh throws shadows with weird corners and edges (stationary light)

Hello there!

First im new to Unreal and Blender. Its my first time using a game engine and 3D modeling software. And please excuse my bad english ^^

Problem:
I’ve created a raw cabin shaped model in Blender and imported it into Unreal to test lighting and if everything “is working”. I noticed that shadow shape my objects creates is correct but some details are completely wrong. On the first picture you can see one corner. It looks like the shadow is “bleeding”. On the second picture you can see the corner under the roof. I dont know how to describe it but you should see it especially the dark line on the top mid. (Picture 3 gets mentioned later its something different!)

What I tried:
As I said before Im a beginner but there are still some few things I tried:

  1. Increasing the ‘Light Map Resolution’; Increasing the Resolution of the object and the ground doesnt help. Both are set up to values above 1024. Increasing the number doesnt have an effect.
  2. Creating own Lightmap UVs in Blender and exporting them to UE; This gives me completely wrong shadows. Faces that facing the sun have ‘spotted’ shadows which doesnt make sense. Im currently using the Unreal generated Lightmap UVs which are working way better but still having issues mentioned above.
  3. Recreating UVs/using higher or lower ‘Island Margin’ values; Doesnt have an effect. Im currently using ‘Smart UV Project’-UVs with the default settings but an ‘Island Margin’ of 0.1.
  4. Remodeling, reimporting, restarting, reinstalling; Nothing works. I recreated my model multiple times and even using the rough shape like I do at the moment has the issues. I even reinstalled UE three times and even tried other versions (4.26.2, 4.27.1, 4.27.2).
  5. Changing ‘Shadow Bias’ value; Doesnt have an effect.
  6. Using movable light; Yes this indeed fixes my issues but leads to another problem. The shadow distance is too low for my “game”. When Im using my more detailed model shadows the model throws on itself are disappearing. Increasing ‘Dynamic Shadow Distance’ makes it worse. There are some threads like this that having the same issues but most of them found fixes. These arent working for me. In my game 99% of the shadow will be static thats why I want to use baked lighting.

Help I got:
I’ve got some help from experienced people on Discord. They suggested these possible solutions and probably some few more I forgot. Nothing worked. If you got another solution please tell me^^

I will link my .fbx and the mentioned pictures. Thanks to anyone helping^^

// Stationary


// Movable

Can you post a screenshot of your UVs and Lightmap for this model pls?

Greetings CrazyFinnGmbH,

Welcome to the Unreal Engine Community! We see that this is your first time posting in our forums! :medal_sports: We immensely appreciate you for being an important part of building a stronger community! :muscle:t4:

Thank you for including such detailed information and images to describe the issues you are having! I see that you are new to both Unreal and Blender. Have you had a chance to view the Unreal Documentation on Shadow Casting? Please check out the link here. I hope this leads you in the right direction. Please let us know if this helps!

Hello^^
Thats just the basic stuff im familiar with, I think. There was nothing new to me.

Yep, sure. First Picture is the ‘general’ UV and the second one the Lightmap UVs (generated by UE).

// Im sorry for posting two answers. I thought that I comment on the posts not creating own “answers” like you do on reddit. I posted a wrong picture im sorry ^^


In your directional light, try enabling “Use Area Shadows for Stationary Lights”

Sorry for my late answer I had plenty of other stuff to do.
Unfortunately your idea doesnt work. The shadows are now “blocky” as you can see on the picture below.

What does your lightmap density view look like?

Like this: (Resolution of 1024. When I decrease the resolution the density squares are visible again)

Not enough lightmap resolution, basically. The resolution number is mostly meaningless, 1024 might sound high resolution but it is virtually nothing on a large mesh with a poor UV layout (the default template floor is just a rescaled cube, it has awful UVs).

The density visualizer provides a much better view of what your optimal lightmap resolution should be which is why I asked you what it looked like.

As a general guide (just my own personal thoughts on this):
Blue = Too low
Green = Okay
Yellow = Optimal for quality (in my opinion)
Red = High

With that in mind, your floor lightmap resolution is way too low, while your triangular structure is okay.

The higher the resolution, the more shadow detail you can expect. This is an example from one of my scenes, lightmap density view on top, lit view on bottom:

To which number should I increase the number?

Lightmap resolution of your floor mesh

Even after changing the Resolution up to ‘4096’ there are still weird edges. On the mesh and on the ground (both have a res. of ‘4096’).

Edges like this on the floor:

And like this on my mesh:

If I deactivate ‘Use Area Shadows for Stationary Light’ the shadows are way better but my first problems are back again…

Really not sure what I’m supposed to be seeing here…

If your hope is to get infinitely detailed shadows then your only option is raytraced shadows in UE4. If you use UE5 you can use virtual shadowmaps but that comes with its own caveats.

The edges are shaped like a knife. They are not smooth like they are when Im using movable light.