Download

Mesh not showing up in either Character BP or Animation Preview

As an update from my last post: How to import modular assets from VROID to BLENDER to UNREAL?

I have learned more about Unreal and was able to successfully map the UE man skeleton to my VROID mesh(through MIXAMO and then retargeting). I am on the right track towards getting the modular parts I need to work separately for my character creation system.

My current issue is when I load the mesh into the third person blueprint or preview an animation it just disappears. I initially thought it was because of scale but in the TPP character BP no matter what scale I put it to uniformly it will not show up. Any advice is greatly appreciated thanks in advance.

Are you updating the character animation blueprint when you swap the skeletal mesh in your TPP character BP?

Yes, I did initially and tried again but it will not show up. This is the tutorial I followed: Take your Mixamo Character into Unreal Engine as a Playable Character - YouTube.

I thought it wasn’t the scale as my unit scale is 0.01 in Blender and I use the Blender2UE4 addon(in Blender) to at least check my scene and make sure my export is on the correct scale. But I found this little guy floating around. I can tell his leg is messed up but I’m not sure if that happens to be cuz of the size issue as when I move the bones around nothing breaks.


Any advice on how to fix?

hjnk .,
Scale unit in Blender prior to exporting

Usually if there’s an issue with the animBP i’ve found it can cause an issue like this, but from the looks of it now you’re seeing the character in your BP it’s just extremely small? Have you tried dragging the character skeletal mesh into a scene and seeing whether it scales properly? Just to rule out it being an issue with the base skeletal mesh vs the animbp or bp. If you still can’t see it when dragging the SKM onto the scene, try playing with the scale values again and see if it still remains hidden.

  • This is Scale issue, mesh size is just 2×0×2…

  • If importing to blender,
    It’s required to set blender units to 0.01 meters before importing into blender,

  • If blender units changed after import, then, mesh scale will also change automatically, so, here required to scale mesh accordingly…

  • And then export to ue4.