Mesh not rendered if rootbody not in frame

Hi,

I have a problem that my physics simulating assets are not rendered as soon as the root body is not in frame.

Here the root bone/body is visible, so the mesh is rendered.

And here the root bone/body is not in frame anymore, so the mesh is not rendered.

I thought if I check “Consider Body for Bounds” on the other bodies would fix it, but it doesn’t do anything. Is there something I’m missing?

Best regards, Joey

Hello dj_joey,

I am sorry you are having this issue. From what you describe and your screenshots you have a skeletal mesh that you have moved the root-bone outside of the rendered scene. As soon as you do this then the textures disappeared.

I have created a test with a skeletal mesh and opened the PHaT editor. I am unable to move the root bone.

How exactly are you moving your root bone?

Thank you,

Logan

Hi Logan,

So I figured out that the mesh becomes invisible only if the rootbody is set to Kinematic.

This is also happening to another skeletal mesh of mine. It’s a rope with the rootbody set to kinematic. As soon as I don’t see the rootbody anymore the rest of the mesh is invisible.

It looks like this:

And if i rotate the camera a bit down so that i don’t see the beginning of the rope it looks like this:

58308-2015-09-12+09_39_31-invisibilitybug+-+unreal+editor.png

Here is a small project to show you the problem:

Just hit simulate and look at the one end of the rope and make sure that the fixed end of the rope is not in frame.

So to your initial question: How am I moving the root bone from my character.
I didn’t. The rootbone on my skeletal mesh is kinematic and the next bone can move freely. I do that so that I can simulate physics on all bones except the rootbone and can blend seamlessly between full-ragdoll and animation.

Am I doing something wrong? Should I not use Kinematic on the rope and character? Or is this a bug with the bounds?

Regards, Joey

Hello Joey,

I downloaded your project and tested your rope out. I tested it both in the viewport when pressing play in viewport and inside of your skeletal mesh editor when pressing simulate.

This is the result in mesh editor.

This is the result in viewport.

I ended up changing the rope to blue just so it could be seen better against a grey floor.

In both cases I did not see the texture disappear.

Logan

Hello Joey,

Have you had a chance to look into this issue any further? It’s strange that I cannot reproduce this on my end.

If you could link me your DxDiag. I’ll see if there is a hardware/software issue reported with your computers specs.

Thanks,

Logan

Hi Logan,

Sorry wanted to answer earlier but didn’t have time…

Did you try moving the camera down some more? so that you just see the hanging part of the rope and that the part that is lying is not visible anymore…
Like I did in my screenshots… I added 2 platforms just for the screenshots. You can see in the second picture that the platform, where the rope is lying on is not visible anymore because the camera is rotated down.

Or maybe try just following the rope from one end to the other with the camera and make sure that the starting position is not in the direction the camera is facing…

If you still can’t reproduce pls tell.
Here is my dxdiag: Dropbox - Error

Joey

Hello dj_joey,

I was looking through your DxDiag and noticed that you last updated your graphics driver on 4/2/2012. If you would update your drivers and then retry this.

Let me know if this fixes it. I did go through and moved around the rope so that just the hanging part was in view. I still did not see the blue material revert to a default material on it.

This would also not be consistent with your first image that had the whole mesh still visible on the screen. I am curious to see if updating your graphics card fixes the issue though.

Logan

Hi Logan.

Yeah that’s the Intel Graphicscard but I use the GT650M for Unreal Engine… Intel is not updateable because of Asus-reasons…

But I just updated the nvidia driver because it was also not up-to-date… and UE to 4.9.1…

Still same results…

Here is a new Zip:

In there is a video of me moving the camera so you can see better…
I also updated the project with a Matinee… Just start the project, press Play and watch the matinee… I also included a video of how the matinee looks like on my pc…

Can you now reproduce this?

Joey

Hi Logan,

good that you are able to reproduce it.
Cool thanks.
You’re welcome.

Joey

Hello dj_joey,

I downloaded your project and I am able to reproduce what you are seeing. I’m not sure why it is happening. I tried all the troubleshoots from rendering the material, to changing the bounds, and moving the rope to the edge.

This does indeed seem like a bug with 4.9.

I have entered a bug for you. The ticket number is UE-21180.

I will keep you posted on this bugs progress.

Thank you,

Logan

Hey dj_joey,

After feedback from the developers this has been marked as by design. What it sounds like is that your bounds are off. You either need to adjust your bounds or create a physics asset.

Logan

Hi Logan,

could you please explain what you mean with “the bounds are off”, I checked "consider body for bounds"on every single body in phat but this doesnt help.

and what do you mean with “create a physics asset”? This is already a physics asset so what should I create?

I just want to see my ragdoll of the character & the rope (& other physics assets) even if I am not facing the direction where the root body is lying…

And why does this only happen if I set a body to Kinematic, so that the position is fixed?

For example how would you change the rope asset in the project I posted above so that it’s always visible?

Best regards,
Joey

This is from another user who had a similar issue.

They adjusted their bound scale so it would encompass their entire object.

Logan

ok thanks Logan.

looks like increasing the bounds in the Rendering section did the trick.

Joey

ok no it didn’t… The bounds are bigger yes… But if I have a part of the physics asset that can move freely from the kinematic part of the asset and the distance between these two parts gets too big I have the same problem… Why does the option “Consider for Bounds” not help?

Joey

My guess is that is more for larger items and not so much for individual joints. Set the bound to something ridiculous and see if that keeps everything within it.

Logan

Ok I didn’t see that I can write any number I want into the field.

So if I set the bounds for my characters to 10.000 will this have a major impact in performance?

Joey

I don’t believe so. This is just a calculation for where things are. One draw call encompassing the character trying to see if it is or isn’t inside bounds.

Ok. Thanks for the help.