Download

Mesh Decals. Distance modulated WPO

When I apply a decal material to a mesh, the mesh faces are offset more as the camera moves further away from the mesh decal. Presumably, this is a feature to prevent Zfighting on distant decals. The problem, is the decal is offset FAR too much. How can i adjust this feature or turn it off?

For anyone who is having the same problem, there is a (hacky) workaround: simply enable flat tessellation in the material, and the automatic WPO will disappear.

Found this on google after still facing the issue in 4.24, so surprised this strange workaround actually works. Thanks for finding it back in 2018!