Download

Megascans master material Normal issue?

Hi, I was importing megascans into UE4 and they all looked terrible.

After some troubleshooting, I found that their normal map is behaving weirdly, it’s inverting itself at certain frequency.

Here’s a comparison of an empty material with the megascans normal mal applied, and a megascans master material with just the normal (on the left)

it happens to any normal map that I put into the megascans base material.

why is it doing this? how can I fix it? I didn’t want to start a new base material from scratch since the megascans material already has some interesting params

Probably have a better chance getting an answer if you actually posted the material.

I gave up on using bridge to bring content into UE4 a long time ago and just started building my own materials and importing just the maps. I suspect I’m not alone there.

I was subscribed to MS at one point before they joined Epic. I quit because I couldn’t get the materials to look right. Quite often, it looked like the normal was inverted.

I gave up…

Never even tried Bridge materials.

Why would anyone? It’s probably just an overloaded material that eats at performance without any benefit.

Right click the material in bridge, click the show files option, and push the textures to unreal.
Then set up in the instance of your custom material however you want.

As far as the inverted normals go, it’s not the first report I have seen asking about it.
No, the normal maps aren’t inverted. But the material has options that do mess with the normal allowing you to invert it, so check the instance settings.

As far as PAK images go, I pass my textures (my own too) I to quixel mixer and output what I need into RGB channels.
Can’t use A yet, but 3 out of 4 isn’t bad.

1 Like

I think the goal is that for less technical users, using bridge would “just work” for getting assets into Unreal. Unfortunately that was not the case when I tried it and evidently, it still isn’t.

3 Likes

yeah I guess I’m using my own master mat.

the weird part of their material isn’t htat it inverts the normal map consistently, it’s like if I had a tiling gradient ramp multiplying normal values by 2 to -2. I wouldn’t be able to do that myself if I wanted to

Makes me think it might be expecting a detail normal map that isn’t present.

I disconnected everything related to the detail normals and it didn’t do it, but unchecking “use adjusted maps” makes it go away, so it has to be something bad in the normal adjustment nodes this material uses:

but I’m done troubleshooting it, a base material from scratch is already working way better!

1 Like

That’s a pretty weird setup, not sure why anyone would want to rotate the normal vectors.

Tbh I don’t see anything here that would create the problem you have pictured.

Not important anymore I guess, making your own material was the right way to go imo.

1 Like