Download

Megascans foliage material flickers with message "Your scene contains a skydome, but it does not cover that part of the screen."

Hi, I am trying to test the new Megascans trees in my project. I have disabled a number of shader permutations in this project and no doubt one of them is causing the material to not render correctly as seen above.

Update:

it’s due to forward shading. I wonder it if it possible to make this shader compatible with forward shading then.

Okay here is something unexpected:

If I simply turn on the Advanced Wind boolean - nothing more than that - it solves both the flickering and the skylight warning message.

I’ll mark that solved. I cannot say why it works but it does. Now I am able to have these foliage assets render correctly in my project that uses forward shading simply by setting the “advanced wind” parameter to true. Also of note, I am using the “simple wind” material, as opposed to the pivot painter.