media textures not showing up in render

I have 2 media textures that are playing windows media files and everything works fine in editor, but when I try to write out frames with matinee, those textures are not showing up.
I tried to change the media texture from play from url to play from memory, but then that caused unreal to crash and now I am unable to open my level at all, it now crashes before loading. Anyone have any suggestions? Thanks

Hey Spectral Illusions,

There was a know and reported issue with the Media Player Framework not functioning as intended when using the ‘From Memory’ option. This issue was causing users projects to crash and corrupt after attempting to package, so we decided to remove the option altogether. This has been removed in engine version 4.9, so users will no longer experience the associated crash.

To get your project up and running again, firstly, create a copy of your project, usually located in the C:\Users\Your.Name\Documents\Unreal Projects directory. In the copy you just created, open the ‘Content’ folder and delete the media player .uasset(s). They will be named however you named them within your project. Be sure to find and delete all the .uassets and content associated with the media player. Now attempt to open the copied project to see if it works.

Let me know if this worked for you, or if you need further assistance.

Thank you,

Hi Andrew, Thanks for your response. I was able to open my project again after deleting the media files.
I still have the problem of the textures not showing up when I launch a stand alone game or try to write out frames.
The movie files are in the movie directory, and they work in editor. I’ve had it working in 4.7, should I just move on to 4.9? Thanks again.

Since the Media Framework is being improved with each iteration release of the engine, I would suggest moving to a build that has a more stable version of the feature you are attempting to use.

Keep in mind, 4.9 is in the preview stages currently, and it is suggested you do not move any important projects or work to these preview builds as they are not meant for the production pipeline but as a preview of things to come in the final build.

Media Framework Documentation

I would wait until the full release of 4.9 before moving over and testing this issue. The issues you have mentioned are known and we are working to have them resolved and fixed in an upcoming release. The documentation provided should give you some insight on the current status of the feature. You can also check out our Forums and Release Notes. Both can be found from the main documentation page.


Hi Spectral Illusions and Andrew!

I have the same problem of mine, I tried in 4.8.3 and 4.9.3 preview version, the problem was not resolved.
Everything works fine in editor, but in the packaged project or in exported matinee not working the textures.
I created a media player from a wmv file, the file location in the "project/content/movies folder, I tested everything already but nothing works. I don’t have idea…


Hey vnmber,

As mentioned earlier, this is a known issue and is planned to be fixed for a major upcoming release. Refer to the documentation and references I provided in my previous post for updates in regards to issues known and reported.

Thank you,