Download

Media Texture video playback too fast in sequencer render output

I have a media texture in my scene that plays an onscreen video (like a television in a living room). Everything is working fine when i play the level, and works fine as I scrub through the level sequence i made, which i’m rendering out as an animation. However, when i render the animation, the media texture that’s playing on screen is playing 3-4x too fast. Is there any way to slow it down for the level sequence only? I’d still like it to play at a normal rate when playing the level.

Thanks.

A couple of things. Have you matched your sequencer frame rate to be the same as your video clip for the tv screen?

Also when you record your sequence, you should match your frame rate here as well. If your timeline is set to 30FPS then the recorded frame rate should match this as well.

I always use Media texture files as they give me consistent results

I have the same problem. It’s not a mismatched frame rate. I think it’s because sequencer is recording at a slower rate to gain quality but the video is playing out at game frame rate. I’d love to know if there is a way to keep them synced.

The workaround (4.22.3) for this is to convert the mp4 into an image sequence (yes, it’ll be a lot of files) then create a file image source for that. The tv video should open this instead and playback will be at the correct speed when rendering the sequence.
You don’t want this setup for a packaged build though, it’ll be huge.
It’s a pain but it works. If anyone has the real solution I’d love to know or is it a bug.

Just wanted to say in 4.25.1 this still exists as a problem, shame movie playback isn’t forced to the output speed!

Hello Dear community, can someone help us to solve this problem? I’m using 4.25.3 and have been facing this problem from 3 years ago. Thanks in advance it would be much appreciated

Render the sequence out as a set of *.png files and then use an app like Davince Resolve (free) to create your mp4 file. Use that file to play it on your TV screen. Definitely works.

I’m experiencing the same thing. I have produced my MP4 from an image sequence. The Unreal Sequencer playback is still broken in Unreal 4.25.3.

The fast speed image is from the Sequencer.

The normal speed image is from engine playback.

I’m a bit confused, sorry. I try to figure out what you guys are trying to say. I have been doing both recently without problems. I am playing a mp4 movie on a TV media texture and the speed is as expected. I also can play a sequence in game / run-time on screen without a problem. Are you trying to run the sequence directly on the media texture? Like with a surveillance camera next room showing what’s in the other room on TV?

The problem shows up when you use sequencer to render out your sequence (as mp4 or individual frames) and you have a media texture in that scene playing a video. Rendering like this is not real-time and if you examine the end result (the output .mp4 or individual frames made into a mp4) you find that the media texture playback speed is all wrong.
Unless you apply the workaround I described above.

Thanks for clarifying. I just checked it out rendering a sequence with a movie playing on a TV screeen (media texture). And yes - During recording the TV movie played at the correct speed. But the recording was slowing down the frames per second. In the rendered movie the movie on TV plays way too fast. It would only work if the capture would be at 50 fps real time speed. Good to know.

How did you get the sequencer to record the video? I must be missing something, because I only get a white texture…

It has to work during game play. Does it stay white when you play the game? Must be a wrong setting in the media texture. Open the media player asset and see if it plays in there.

Not sure what I changed but it started showing just fine.
Must have missed something in the media texture settings as you said.
Thanks!

Hi all, I’m still having this issue in 4.25.3. Is there any solution to this yet? Are we expecting a fix in 4.26.0? Thanks all

IslandPlaya has mentioned before, use image sequence for playback in sequencer. I was doing that for 4.25.3 . Do not use 4.26.0 for image sequence, it will fail!

Please Epic for the love of all that is good fix this. No matter how awkward it is for you to do so.

1 Like

I had this issue ( When rendering out sequencer scene with a TV playing Media Texture on it), You playback the render and the video on TV screen is way too fast. To fix it go into Level Blueprint, where you can set the speed for the Media Texture and slow it down from an Event tick. Please see Blueprint and example attached. Create a variable called TV Screen which is a Media Player type, pointing to the File Media Source. Then add Set rate node and Multiplication node to rate on Set Rate Node. Connect Set Rate and Multiplication node to event tick. Make Multiplication node a really small amount. ( I used 0.09) This worked for me. It might not be 100% accurate but it slowed the Media File on TV down to an acceptable speed.

Thanks Graeme, this is a good work around i’d say, although for me I multiplied it by 3.5 instead of 0.09 so i’m guessing this is going to be different for everyone.

I’m currently rendering 24fps at 2160p, tried doing 24fps 1080p and it turned out the same which wasn’t what i expected.

Hopefully we can get a good workaround for all as i cannot get normal play even with image sequencer which is the only way i render to get smooth playback when not using media textures.

Also using Unreal 4.25.3 in bootcamp on a mac pro 2013 if that helps anyone troubleshoot.

Hi, I’m a cinematographer quite new to Unreal. I have the same issue* for chroma keying. I’m trying to synchronize an actor inside a video texture within a sequence, the problem in my case is that the speed of the video texture gets slower depending on the resolution of the rendering… becoming useless…
It’s really a pity because the preview is really awesome…
I hope UE team can help with this! Pleaseeee!