Media texture not working

when i run my .exe my media texture, with my movie in the content/movies, doesn’t play. i tried putting in another location and it worked [i created a c:/videos then it played]

Any suggestion?

Media files currently have to be located inside /YourProject/Content/Movies, otherwise they will not package/deploy.

Having the same problem with 4.9. Movies are black on a Standalone Game. Everything worked fine with older versions but not with 4.9. I am triggering the media texture with play in blueprints. My media is in a Movies folder. No luck.

As i said, my movie is already inside this folder and still not working during the package…

How are you packaging your project?

Are you using the Shipping or Development build configuration?

I have the same issue, doing both Shipping and Development. In the packaged folder, I already see the movie file located in the content/Movies/ folder, but it doesn’t play.

Hey Xerafel,

Could you provide me with the engine version you are working in, and the video format you are using? i.e. 4.10.2 and .h264 encoded media file.

Also, what platform are you packaging for?


I get a similar problem. My UMG Media texture plays fine uncooked and in editor. But after package (Development) it turns black. A message flashes by saying: “Texture Streaming Pool Over 20512.00 MB” The movie is 62.5 MB and it all looks good when checking the stats. Also tried to pump up the streaming pool size without any luck…
Could there be a movie file-type issue? Right now we use AVI files (Get the same result with Shootinggame Loading.mp4 though)

Take a look at our documentation. We state that there are known issues with certain encoded media files and file types such as .mp4

Media Framework

The texture streaming issue means you are going over the allotted Texture Pool Memory size, and some of your textures are being streamed out of memory. This is a separate issue from the Media Framework issue, and we ask that you create a new AnswerHub post so we can track the problem on its own thread.

Thanks for a fast reply, my new question is here: