Media texture displays as white after version update


Just tried out .18 preview 4 in search for the solution of a different problem (scene with more than one 3d Widget is jittery in Gear VR. It helped), and encountered that. Media assets transfered with the project got borked. Reference to the media file is correct, and it was transfered automatically to the new version. I’ve set texture sampler to “External”. Everything looked as it should, but surface with media material turned white, and nothing could change that.

I guess, working solution is to delete old assets and reimport/set up everything from scratch, but… I guess that could be considered a bug.

What I did:

  1. Created a .17 Mobile project
  2. Imported Media file into Movies folder (and physically copied mp4 file to the folder), fixed local link.
  3. Created a Media player with Media texture with that file.
  4. Created an Unlit Material with that texture.
  5. Set up blueprint command to open it (It played, in GearVR build too)
  6. Opened project with .18, checked all links and files, everything is in order
  7. Set texture sampler to External to resolve new kind of error

Surface with the material is white in both editor viewport and in the build on the device.

After upgrading to 4.18, you also need to select the MediaPlayer in your MediaTexture. In 4.17, the MediaTexture was assigned to the MediaPlayer. In 4.18 it is the other way around. We didn’t have time to upgrade that setting automatically, so you’ll have to do it by hand.


Ah, I see now! Thank you!