Media Player playback causes "shake" in VR headset

We recently made the upgrade to 4.17 on a long standing project that had no problems before. After the update I noticed that in the headset the scene “shook” as though it were dropping frames and forced to reproject. This is not a frame rate issue however, I have done all kinds of performance testing. We finally remade a fresh project and migrated everything over to it, and thought we fixed the problem until I re-implemented our video. The effect returns when a media player in the scene loads a source (local) and begins playing it.

Fixes I have attempted:

  1. All kinds of video settings, from absurdly low bit rates to different codecs.
  2. opened a fresh project with nothing but the default scene and a video player (also tried all the different re-encoded videos)
  3. Removed material displaying the media, it still occurred.
  4. The content example works fine, so I emulated its encoding settings, still causes the issue.

The video resolution is 2048 and we can’t compromise on the size as we are using quadrants to pass different data to the material.

I won’t add this as a solution because it doesn’t seem like a true solution. It seems the most affecting factor is video resolution. The sample comes in 16:9 format, and when resizing our video (from 1:1 square) it plays back fine. This is limited by resolution to 720 however, and does not solve the problem for us as we required the quadrants. It does seem that we can get two playbacks at 960:540, so we will go with that for now and hopefully the playback issues will be addressed in a future hotfix.

Hello JeffVRP,

I ran a few tests and I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project (not by migrating old assets)?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. If not, could you provide a simplified version of your project that reproduces this issue so that I could take a closer look?
  4. Could you provide screen shots of any settings/blueprints that may be involved with this issue?

Hey Rudy, I have a project to attach. It has multiple versions of the video we are using and should hopefully outline the differences in performance with each video. It is a little less than a gigibyte in size however, how can I upload it for your review?

If you would like to provide a project, you could do so by zipping it down and providing a link via drop box or google drive in a private message to me on the forums.

I’ve uploaded the project here:

Hello JeffVRP,

I was able to reproduce this issue on our end with the project provided. I have written up a report and I have submitted it to the developers for further consideration. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-49184)

Make it a great day

This needs to be fixed. I am having an exhibition right now, and I just discovered that my project will not run properly because of this bug. I am extremely frustrated at the lack of a work around for such an obvious bug.

Hi Rudy, I see that the issue is marked “Won’t Fix” and there’s no mention of a workaround or any details at all. I have a similar issue in 4.17.1. The sample video from the Media Framework plays acceptably, but the only way I can get our media to do so is reduce the resolution to 640 * 360.

Just adding that this is with the Oculus on windows 10. I put together a test in 4.16.3 using the VR HMD example with a single media player and a plane. This works fine, but opening a copy of the project in 4.17.1 leads to the shaking issues when the media is playing. I’d rather not reimplement my larger project in the earlier version, so if there’s any kind of workaround please let me know.

Are you kidding me? Won’t Fix? I am flying to another country tomorrow simply because this issue is effecting a project of mine and now I am forced to go have meetings with colleagues as well as manually migrate an entire project back to 4.16. Please do explain to me how this is not an issue that needs to be fixed.

I get it, not every UE4 developer uses VR, but that doesn’t mean that there are not a ton who do.

Yes, I am with you all. We have an important demo that relies on this feature working, and it’s not acceptable in anyway just to label “Won’t Fix” without any explanation for something so important.

Hello ericrius1,

The reason for the won’t fix for the link above is due to the project not making frame rate, hence the stuttering. I hope that this information helps.

Make it a great day

Hi Rudy,

Sorry that is not helpful. The stuttering is of course caused by frame rate issues.

The issue is that playing media in 4.17 causes the project to have a reduced frame rate and playing the same media in 4.16 does not. This is easy to demonstrate with the 3rd-person project and the step-by-step instructions from the media player docs.

The consequence is that 4.17 seems to be unusable for anyone who wants to play anything but the lowest quality media in VR, unless there is some workaround.


Same issue, also two days bf exhibition opening ( had to spend all the time fixing in instead of actual work). Had to somehow use 2 video textures instead of 4 , then shakiness dissapears.

This needs to be changed from won’t fixed. It’s been months, there are many reported cases of this not being an issue in 4.16, but appearing in 4.17. At least tell us why Epic believes that taking away features is making the engine better.

Rudy, issue still here 4.18 - glitches with no frame rate drops

The Target credit card also known as Red card where you get products with low prices and cashbacks.At Target stores, you can complete payment through Target credit card login

I was using to pay my dues of media player I bought. But target was compelling me to create My REDcard account and then login to target credit card account to make payment. Finally I was successful.

This problem is in the version 4.20.3, i didnt try it in the two newer versions, but this is not acceptable.