Download

maya to udk 4 and weird rendering artifacts

I have spent so many hours trying to figure this out and I feel like I am about to cry. This is the geometry that I’ve tried to export from Maya to UE4. The geometry surface is clean and has smooth sharp specular kick on the surface.
6ab8440bbc4a3bcd463ef611ee52a39fcc0226da.jpeg
This is what the wireframe looks like
wireframe.jpg
I’ve tried many different export settings in maya, suggested by other people. But nothing has worked so far. I have tried 2013 fbx, 2014 fbx, smoothing group on, triangulate, etc… I also downloaded the blender3d and tried to export from that software but got same result.
When I imported this model into UE4, this is what the specular looks like. BTW, I tried all different import settings in UE4 to see if it makes any differences but again nothing has worked.
50c1113079bf31923d0cfd32997af1ee103a5d71.jpeg
I don’t know how to describe this look. The specular looks faceted.
This is a bit more close up picture.
cdf601263135b8bfd7f024dd7caf419473dd2245.jpeg
In a way, the specular reveals the topology of the triangulated mesh that I imported.
From an another angle
differentAngle.jpg
This artifact also shows in reflection as well.
reflection.jpg
You will see faceted edges on the border between white and black.
I thought it was maya export settings issue but as I said before, I also tried export from blender 3d as well and got same result.
At this point, I just have no idea where this artifact comes from.
Any guess? help? Thanks in advance!

Things that I have tried so far
maya->unlock normal->smooth edge->lock normal
maya->export obj instead of fbx
maya->export->both fbx2013 and fbx2014 (tried many different settings including UDK doc)
maya->create a light map uv with auto-mapping
maya->rebuild the surface from scratch
maya->delete all faces except few rows of most smooth curvature faces->export fbx
blender->smooth edge->export fbx (tried many different settings)

It looks like it’s not importing your smoothing, make sure that the FBX exporter has the option checked to include smoothing. Also make sure that in UE4 you have it set to import normals rather than generating them

Also, you could make that mesh much more efficient with a lower polygon count, you really only need more polygons around the chamferred corners

Yeah, looks like smoothing groups not carrying over, so try that first. But sometimes in max (don’t know about Maya), the mesh vert order gets really messed up, in that case try going to polygon level > select all > detach as element (and clone) > invert selection and delete. This will make exactly the same mesh, but will reorder vert number. That seems to be the solution sometimes.

just tried darthviper107 and BrickTop method and still same issue. To me it is a bit different from hard or soft edge issue. Overall the surface is smooth as expected but spec and reflection have some weird artifacts. More I zoom into the highlight, it becomes more pixelated and faceted. hmm… Thanks for your suggestions anyway !

Well, if you don’t mind uploading the mesh somewhere, I can check it out. As a quick hack, try using super fine noise for your roughness, it may break up those artifacts.

Okay. I don’t have 3dsmax so I couldn’t try reordering vert number. So today I did it in maya by manually changing the vert position to reoder them in right order and it seems to solve the problem. THANK YOU SO MUCH!

Great! Glad you fixed it :slight_smile: