Max In-Game Texture Size Limitations?

I have high resolution texture maps but when I open them in UE4 there is a dialogue box in the top right hand corner that says max in-game texture size is exactly half of this!

7000x7000 might say max in-game is 3500x3500
6000 would be 3000

What do I do? Does it make sense to output these huge texture maps only for UE4 to limit them in-game?

4096x4096 max in-game is 4096
3000 max in-game is 3000

How come these higher resolutions don’t have max in-game the same resolution?

Does it make sense to have texture sizes above this #x# scale?

Like for those high spec computers…would changing them to the UE4’s Max In-Game actually make it worse some for them?

Any help is greatly appreciated. Thanks! (:

I open the texture and this is in the top right hand corner of the screen:


No clue what you mean because your question is really vague.
On another note, only use power-of-two textures, so DONT use 7000x7000 or 3000x3000. max resolution is 8192x8192 afaik.

well, as I said. use power of two.
DONT use a 7000x7000 texture. it will probably work with a 8192x8192.

Bumping up the resolution, should I add compression at all? How will UE4 handle it w/ or w/o compression?

You should really read up on the wiki and google search more before asking questions that can easily be answered with a simple google or answerhub search.

power of two images (256,512,1024,etc,etc) work better since UE4 can mipmap them (another word to google) which helps with performance.
Dont compress textures before importing them into ue4 as UE4 has its own compression system specifically made to work as good as possible for gpu’s.

you could also reduce the texture size to 4096*4096 instead.
Not many things currently need such high res. textures.

So why is the Max In-Game resolution half of the texture size on bigger textures? It’s doesn’t matter if it’s power of two or not.
I need a 8192 x 4096 texture and my graphic hardware supports it. The texture is recognizable smaller/blurier in Play mode and packaged game. Is this a bug or what? Or is the worlds best game engine limited to 4096 x 4096.
If this is so I have to split my geometry in half and use multiple smaller textures instead of a big one.

And please read the OP question carefully before you start the old “read the f***ing manual” speech. This has nothing to do with power of two.

First thing that popped up on google for “unreal engine 4 max texture size”. Straight from the manual.

Documentation needs to be slightly updated but this should help as well:

In other words, a typical GTFM?
(Google the bleepin manual)

Also, really not fond of the way Vangel asked that question, we are all way more inclined to answer without sarcastic remarks.

Tim Hobson’s answer in his forum post is the best. The UI seems to have changed/been made more robust, since then. I believe the default project device must not be Windows. It may need to be changed in the Android settings, for instance.

-Go to Window > Developer Tools > Device Profiles
-Click on the device name > TextureLODGroups Setting
-Change the Max LOD Size
-Click the “Save as Default” at the top

Also, DeviceProfiles.ini in project location, [YourProject]/Config/DeviceProfiles.ini, (not the editor install location) has [/Script/Engine.TextureLODSettings], then that is the master override for all TextureLODGroups. This is Unreal’s comment in the .ini on their documentation page:



Also note (because there is not much documentation on this):

"To create a device profile, edit your project’s DefaultDeviceProfiles.ini file. Make sure to add or create a section called [DeviceProfileNameAndTypes]. See Engine/Config/BaseDeviceProfiles.ini for examples.